Red Gate forums :: View topic - Is there a new version of Scream
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation

Scream forum

Is there a new version of Scream

Search in Scream forum
Post new topic   Reply to topic
Jump to:  
Author Message
AndyScott



Joined: 16 Nov 2005
Posts: 17
Location: Warrington

PostPosted: Fri Jul 14, 2006 5:53 pm    Post subject: Is there a new version of Scream Reply with quote

Is there a new version of Scream that can compare snapshots taken from version SQL Compare 5.2? can it compare the new snapshots against older snapshots taken with SQL Compare 5?
Back to top
View user's profile Send private message
richardjm



Joined: 20 May 2005
Posts: 359
Location: Red Gate Software Ltd

PostPosted: Mon Jul 17, 2006 8:18 am    Post subject: Reply with quote

The version 0.2 that is currently out should be able to compare snapshots from version 5.0, 5.1 or 5.2. I built it against the engine from 5.1 although there were no changes to the snapshots for 5.2.

It should also be able to compare snapshots from older versions without any problems.

HTH
_________________
Richard Mitchell
Project Manager
Red Gate Software Ltd
Back to top
View user's profile Send private message Send e-mail
AndyScott



Joined: 16 Nov 2005
Posts: 17
Location: Warrington

PostPosted: Mon Jul 17, 2006 4:06 pm    Post subject: Reply with quote

Hi Richard,
I have upgraded to the current scream downoad and everything is working perfectly again.

Andy
Back to top
View user's profile Send private message
richardjm



Joined: 20 May 2005
Posts: 359
Location: Red Gate Software Ltd

PostPosted: Mon Jul 17, 2006 4:10 pm    Post subject: Reply with quote

Brilliant.

Always a relief when that happens Very Happy
_________________
Richard Mitchell
Project Manager
Red Gate Software Ltd
Back to top
View user's profile Send private message Send e-mail
freddy12345



Joined: 11 Dec 2006
Posts: 19

PostPosted: Fri Dec 22, 2006 9:27 pm    Post subject: Re: Reply with quote

Hi,

Does this work with Sql Server 2005???

thanks,

Fred

richardjm wrote:
Brilliant.

Always a relief when that happens Very Happy
Back to top
View user's profile Send private message Send e-mail
richardjm



Joined: 20 May 2005
Posts: 359
Location: Red Gate Software Ltd

PostPosted: Mon Jan 08, 2007 9:30 am    Post subject: Re: Reply with quote

freddy12345 wrote:
Hi,

Does this work with Sql Server 2005???

thanks,

Fred

richardjm wrote:
Brilliant.

Always a relief when that happens Very Happy


Yes there shouldn't be a problem using it with SQL Server 2005. Or at least the snapshots that SQL Compare generates from a SQL Server 2005 database.
_________________
Richard Mitchell
Project Manager
Red Gate Software Ltd
Back to top
View user's profile Send private message Send e-mail
freddy12345



Joined: 11 Dec 2006
Posts: 19

PostPosted: Mon Jan 08, 2007 6:06 pm    Post subject: re: Reply with quote

thanks for your reply. just tried to install it, and it says setup requries .NET Framework 1.1.4322. We are on .NET 2...i'm leary about trying to install the prev version of the framework! what to do?

thanks,

fred

richardjm wrote:
freddy12345 wrote:
Hi,

Does this work with Sql Server 2005???

thanks,

Fred

richardjm wrote:
Brilliant.

Always a relief when that happens Very Happy


Yes there shouldn't be a problem using it with SQL Server 2005. Or at least the snapshots that SQL Compare generates from a SQL Server 2005 database.
Back to top
View user's profile Send private message Send e-mail
richardjm



Joined: 20 May 2005
Posts: 359
Location: Red Gate Software Ltd

PostPosted: Tue Jan 09, 2007 3:25 pm    Post subject: Re: re: Reply with quote

OK, I've changed the installer so it doesn't require 1.1 to be installed but will work if either of framework 1.1 or 2.0 are installed.

It should work fine with either framework.

Hope this helps.
_________________
Richard Mitchell
Project Manager
Red Gate Software Ltd
Back to top
View user's profile Send private message Send e-mail
freddy12345



Joined: 11 Dec 2006
Posts: 19

PostPosted: Tue Jan 09, 2007 4:17 pm    Post subject: Re: re: Reply with quote

thanks for your quick response!

it installed fine, but it won't open snapshots created with the latest version of sql compare. (i've got 5.30.44)

Sad

fred

richardjm wrote:
OK, I've changed the installer so it doesn't require 1.1 to be installed but will work if either of framework 1.1 or 2.0 are installed.

It should work fine with either framework.

Hope this helps.
Back to top
View user's profile Send private message Send e-mail
richardjm



Joined: 20 May 2005
Posts: 359
Location: Red Gate Software Ltd

PostPosted: Tue Jan 09, 2007 5:19 pm    Post subject: Reply with quote

OK the snapshot format has changed in the latest version so I'll have to do a recompile against the latest engine. I'll get back to you as soon as I can regarding this.

Shouldn't take me long Rolling Eyes
_________________
Richard Mitchell
Project Manager
Red Gate Software Ltd
Back to top
View user's profile Send private message Send e-mail
richardjm



Joined: 20 May 2005
Posts: 359
Location: Red Gate Software Ltd

PostPosted: Thu Jan 18, 2007 10:42 am    Post subject: Reply with quote

Right I've compiled up a new version of Scream with the latest engine from SQL Compare. I've also thrown in a couple of new features that people have been requesting that I'll blog about shortly mainly these are the optional arguments /n1 and /n2 for the names of the two files coming from a Source Control system and an option to turn off showing identical objects.

Have fun with it.
_________________
Richard Mitchell
Project Manager
Red Gate Software Ltd
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group