Red Gate forums :: View topic - MySQL Data Compare wrong charset please help :(
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
MySQL Data Compare
MySQL Data Compare forum

MySQL Data Compare wrong charset please help :(

Search in MySQL Data Compare forum
Post new topic   Reply to topic
Jump to:  
Author Message
S.Lutchko



Joined: 22 Jun 2013
Posts: 3

PostPosted: Sat Jun 22, 2013 9:41 am    Post subject: MySQL Data Compare wrong charset please help :( Reply with quote

Hello,

I hate to cry 'urgent' especially I know it's Saturday now, but unfortunately it is really urgent.

The error is when I'm at MySQL console I can see utf symbols correctly but your app shows it in a wrong way.

Here is the console:

$ mysql -uroot
Server version: 5.1.69-0ubuntu0.10.04.1 (Ubuntu)

mysql> \u src
Database changed

mysql> set names utf8;
Query OK, 0 rows affected (0.00 sec)

mysql> select * from wp_101_posts where ID=17914 \G
.........
#800000">▲</span>Delta<span style="color: #800000">▲</span>
.........

What I see in the app is question marks instead of any utf symbol. I'd like to attach an screenshot but I don't see such option here.

The main issue it puts these question marks in sync script Sad

How can I fix this?

Please help. Thank you.
Back to top
View user's profile Send private message
neil.anderson



Joined: 28 Sep 2010
Posts: 64

PostPosted: Sat Jun 22, 2013 1:55 pm    Post subject: Reply with quote

Hi,

Have you tried setting the script encoding? You can change the charset of the script using Tools -> Application Options -> Encoding.

Thanks,
Neil
Back to top
View user's profile Send private message
S.Lutchko



Joined: 22 Jun 2013
Posts: 3

PostPosted: Sat Jun 22, 2013 2:01 pm    Post subject: Reply with quote

Yes, I did but no luck. As far as I understand this setting is for output script only, not for DB connection.
Back to top
View user's profile Send private message
neil.anderson



Joined: 28 Sep 2010
Posts: 64

PostPosted: Sat Jun 22, 2013 2:52 pm    Post subject: Reply with quote

Ok I've tried to ensure that the connection is set to unicode. Previously it was "auto".

http://download.red-gate.com/EAP/MySQLDataCompare/MySQLDataCompare_1.0.0.492.exe
Back to top
View user's profile Send private message
S.Lutchko



Joined: 22 Jun 2013
Posts: 3

PostPosted: Sat Jun 22, 2013 3:58 pm    Post subject: Reply with quote

Hmmm, now it shows

800000">^</span>Delta<span style="color: #800000">^</span

the caret sign, shift+6

Is it supposed to be so?

I decided to test before post this reply and found that log text fields (text or longtext) in the sync script were truncated to 1024 bytes.

Thanks God, I don't put it to live site and check manually first.

Anyway please take your weekend, I already found a workaround so there is no need to hurry.

Thank you for willing to help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group