Red Gate forums :: View topic - Missing functionality - RESTORE LOG...WITH MOVE
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Backup 6
SQL Backup 6 forum

Missing functionality - RESTORE LOG...WITH MOVE

Search in SQL Backup 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
meastland



Joined: 28 Mar 2011
Posts: 37

PostPosted: Fri Aug 31, 2012 5:22 pm    Post subject: Missing functionality - RESTORE LOG...WITH MOVE Reply with quote

I believe there is a bug in version 6.5.2.21 of SQL Backup. The problem is that the WITH MOVE construct is not available to the SQL Backup implementation of the RESTORE LOG command as it is with the Native RESTORE LOG command. Consider the following log shipping scenario:

A new data file is added to the primary database.
The disk on which the file is created does not exist on the secondary database server.
When trying to restore the SQL Backup log file created after the new data file was created, an error similar to the following is generated:

SQL error 3156: SQL error 3156: File 'NewLogicalDataFile' cannot be restored to 'PrimaryPathWhichDoesNotExistOnSecondary\NewLogicalDataFile.ndf'. Use WITH MOVE to identify a valid location for the file.

When trying to use the RESTORE LOG...WITH MOVE construct in SQL Backup, the following error is returned:

SQL Backup v6.5.1.9
Syntax error: 'MOVE' after 'WITH'

name value
exitcode 850
sqlerrorcode 0

At this point, the SQL Backup file must be converted to the native *.bak format. After the conversion, the Native RESTORE LOG...WITH MOVE command can be executed.

100 percent processed.
Processed 0 pages for database 'DatabaseName', file 'OldLogicalDataFile' on file 1.
Processed 0 pages for database 'DatabaseName', file 'NewLogicalDataFile' on file 1.
Processed 2 pages for database 'DatabaseName', file 'OldLogicalLogFile' on file 1.
RESTORE LOG successfully processed 2 pages in 0.119 seconds (0.123 MB/sec).

And SQL Backup log shipping can continue.

I realize that we are not on version 7 of SQL Backup, so please let me know if this issue is resolved in the current version. That would be sufficient reason for me to support an upgrade to my manager.
Back to top
View user's profile Send private message
Chris Auckland



Joined: 24 Oct 2006
Posts: 757
Location: Red Gate Software Ltd.

PostPosted: Mon Sep 03, 2012 7:01 pm    Post subject: Reply with quote

This doesn't appear to work in v7 either. The help file seems think the syntax should be supported, so I'll see what's up.
_________________
Chris
Back to top
View user's profile Send private message Send e-mail
Chris Auckland



Joined: 24 Oct 2006
Posts: 757
Location: Red Gate Software Ltd.

PostPosted: Fri Sep 07, 2012 11:39 am    Post subject: Reply with quote

Sorry for the delay.

I've confirmed this as a bug with the current and previous versions, and case SB-5388 has been raised for it. This will be fixed and available in the next update.

If you can't wait for the next update, then we might be able to send you a private patch.
_________________
Chris
Back to top
View user's profile Send private message Send e-mail
manferdmanny



Joined: 21 Sep 2012
Posts: 1

PostPosted: Fri Sep 21, 2012 6:24 am    Post subject: SQL Backup 6 Reply with quote

I consider there is a bug in version 6.5.2.21 of SQL Backup. The problem is that the with move construct is not obtainable to the SQL Backup completion of the restore LOG command as it is with the Native RESTORE LOG command. believe the following log delivery situation:

A new data file is additional to the main database.
The hard disk on which the folder is created does not exist on the minor record server.
When trying to restore the SQL Backup log file created after the new data file was shaped, an error similar to the following is produced.



Georgia gate
Back to top
View user's profile Send private message
Chris Auckland



Joined: 24 Oct 2006
Posts: 757
Location: Red Gate Software Ltd.

PostPosted: Fri Sep 21, 2012 9:10 am    Post subject: Reply with quote

That sounds the same as the problem above. The bug report SB-5388 was logged for it and should be fixed in the next update.
_________________
Chris
Back to top
View user's profile Send private message Send e-mail
meastland



Joined: 28 Mar 2011
Posts: 37

PostPosted: Tue Oct 09, 2012 5:11 pm    Post subject: Reply with quote

Chris - Any update on this? Can we expect the functionality to be included in 7.3? I am still running on version 6.5 and will likely wait for this to be addressed before upgraded to 7.x. Thanks in advance.
Back to top
View user's profile Send private message
meastland



Joined: 28 Mar 2011
Posts: 37

PostPosted: Tue Nov 27, 2012 10:43 pm    Post subject: Reply with quote

I have yet to hear back on this. Since I have a support contract, would I be better served by opening a formal ticket?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group