Red Gate forums :: View topic - Profiler hanged after Start Profiling in 8.6
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 8
ANTS Performance Profiler 8 forum

Profiler hanged after Start Profiling in 8.6

Search in ANTS Performance Profiler 8 forum
Post new topic   Reply to topic
Jump to:  
Author Message
gavin.tse



Joined: 18 Jul 2014
Posts: 3

PostPosted: Fri Jul 18, 2014 9:35 am    Post subject: Profiler hanged after Start Profiling in 8.6 Reply with quote

I was able to profile my web application using the profiler 8.5.
However, the program always hanged when I start profiling in 8.6 using the same code of my web application.

Step:
1. Open Profiler
2. Checked all the settings and press "Start Profiler"
3. The web application can be run without any problem. However the profiler is hanged and no response for the "Stop" button.

Any suggestion to solve it is appreiated. Thank you.
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 235

PostPosted: Mon Jul 21, 2014 4:46 pm    Post subject: Reply with quote

Hi Gavin,

Sorry to hear you're running into an issue with the profiler!

Can I please check a few things:

-If your application targets .NET 4+, does the same problem happen if you start your application normally and then attach the profiler to the already running w3wp process using the "attach to process" setting? (If it doesn't target .NET 4+, could you please check instead if sampling mode of profiling gives the same issue?)

-Does it make any difference if you disable "Profile child processes" (from the profiling session set-up view) and "Profiling with async-awareness" (Tools> Advanced Options)?

-Do you see any errors regarding the profiler or your application in Event Viewer (Windows logs>Application)?

Thank you!
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
gavin.tse



Joined: 18 Jul 2014
Posts: 3

PostPosted: Wed Jul 23, 2014 4:29 am    Post subject: Reply with quote

Thank you for the information.

It is working if I choose "attach to process". As it is enough for me to carry on my work, I will go for this option at this moment. Thank you.
Back to top
View user's profile Send private message
gavin.tse



Joined: 18 Jul 2014
Posts: 3

PostPosted: Wed Jul 23, 2014 8:05 am    Post subject: Reply with quote

Sorry for the misleading information in the last thread. I found that it is wrong as the program hanged again when I tried to start the program the second time.

It seems that the problem doesn't appear if it is first started in Windows. If I restarted my computer, the program will hang when I tried to start the program the second time.

I could only see the item below related to the Profiler. But I am not sure if it is generated when it is hanged and I forcibly close the program.

The program RedGate.Profiler.UI.exe version 8.6.0.49 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Action Center control panel.
Process ID: 2a9c
Start Time: 01cfa6430ff6d5a1
Termination Time: 15
Application Path: C:\Program Files\Red Gate\ANTS Performance Profiler 8\RedGate.Profiler.UI.exe
Report Id: 8b832112-1236-11e4-bfd8-005056c00008
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 235

PostPosted: Wed Jul 23, 2014 5:01 pm    Post subject: Reply with quote

Hi Gavin,

No worries!

Just to make sure I'm understanding correctly: when you restart your machine and profile your application the first time, everything is fine, but when you profile a second time, the profiler hangs?

Can I please double check--is this website running in IIS or via the web dev server? Are there any errors related to either in Event Viewer?

If you try profiling a very simple website, does the problem still occur?

If you reinstall version 8.5 (ftp://support.red-gate.com/patches/ANTSPerformanceProfiler/06Feb2014/ANTSPerformanceProfiler_8.5.0.12.zip ) does that work again as expected?
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group