Red Gate forums :: View topic - Trouble generating script for previous version of SQL Server
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Packager 7
SQL Packager 7 forum

Trouble generating script for previous version of SQL Server

Search in SQL Packager 7 forum
Post new topic   Reply to topic
Jump to:  
Author Message
Chillier



Joined: 19 Mar 2014
Posts: 8
Location: Norway

PostPosted: Fri May 23, 2014 2:23 pm    Post subject: Trouble generating script for previous version of SQL Server Reply with quote

I am trying to generate a schema definition script from SQL Server 2012 and run the script on a 2008 version.

Help says there is an option:
http://documentation.red-gate.com/display/SQP7/Creating+a+database+for+an+earlier+version+of+SQL+Server

Specifies:
"Choose the option to create an "upgrade to an existing database"

I cannot find this option...

Question
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 593

PostPosted: Tue May 27, 2014 1:08 pm    Post subject: Reply with quote

Hi- this might be a bit of a doc bug. The packager option is actually labelled:

"Package an upgrade to a database"
Back to top
View user's profile Send private message
Chillier



Joined: 19 Mar 2014
Posts: 8
Location: Norway

PostPosted: Wed Jun 04, 2014 1:44 pm    Post subject: Errors on Sql Server 2008 Reply with quote

Fixed it - a very strange error.

My views contained joins of local tables/views and linked-server tables/views.

The linked-server tables/views had to be LAST in the join sequences for the views to work on 2008.

Go figure...

But yes, the documentation was a bit misleading.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group