Red Gate forums :: View topic - Silverlight 5 / VS 2012
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 8
ANTS Performance Profiler 8 forum

Silverlight 5 / VS 2012

Search in ANTS Performance Profiler 8 forum
Post new topic   Reply to topic
Jump to:  
Author Message
tbeaulieu



Joined: 05 May 2014
Posts: 1

PostPosted: Mon May 05, 2014 9:29 pm    Post subject: Silverlight 5 / VS 2012 Reply with quote

Hello, I downloaded the 8.5 evaluation today in hopes that I will be able to use it for in-house SL 5 development, discovering where my applications are spending their time (which methods) in order to go after the low hanging fruit.

I am not having much luck getting this to work, however.

1. I am unable to run my SL app by opening the host html page directly in IE. This is with or without your tool, so I'm not sure why your documentation describes this approach. It just sits there with the SL loading icon at 100%.

2. I am however able to run the application via the \\localhost\sitename, so that's the approach I've taken with your tool.

3. As others have reported it tells me that it can find no source code. "the profiler could not identify the filepath for this assembly". While the PDB files are in the bin folder, they are not in the clientbin folder, where the lone XAP file is and where my local IIS (not developer webserver) is pointed to for this application. I tried manually copying them alongside the XAP but that didn't seem to work. Not sure if this is related, but I suspect it is.

4. When I run my application it does show up in the tool, but before long IE crashes. The tool works just fine when not being monitored. Between not finding the source code and crashing I've gotten nowhere.

Windows 7, decent lenovo with decent memory.
IE 11
All latest patches and SPs.
IIS 7.5

To be honest I feel like I could use a lot more documentation on how to work with SL applications. Maybe I missed something because I've found little so far (http://documentation.red-gate.com/display/APP8/Profiling+Silverlight+applications).

Thank you.
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 212

PostPosted: Tue May 06, 2014 11:00 pm    Post subject: Reply with quote

Thanks for your post and sorry to hear you're running into some issues!

>> I am unable to run my SL app by opening the host html page directly in IE. This is with or without your tool, so I'm not sure why your documentation describes this approach. It just sits there with the SL loading icon at 100%.

I did a quick test with a simple app and opening the html host file seems to work alright in and outside of the profiler, so sorry to say I'm not too sure what could be stopping the html page from fully loading.

>> As others have reported it tells me that it can find no source code. "the profiler could not identify the filepath for this assembly". While the PDB files are in the bin folder, they are not in the clientbin folder, where the lone XAP file is and where my local IIS (not developer webserver) is pointed to for this application. I tried manually copying them alongside the XAP but that didn't seem to work. Not sure if this is related, but I suspect it is.

To avoid this error, the profiler just needs to be able to find the XAP file (kindly see here - http://documentation.red-gate.com/display/APP8/Working+with+integrated+decompilation )

It sounds like you've may have found your way to this patch already and the issue is now just with integrated decompilation, but can I just make sure-- do you have version 8.5.0.13 installed? You can get it from here: ftp://support.red-gate.com/patches/ANTSPerformanceProfiler/Apr2014/ANTS%20Performance%20Profiler_8.5.0.13_AnyCpu_r233405.zip

There was an issue with version 8.5.0.12 where Silverlight methods with source would not appear in the profiling results at all but the patch fixes it.

>> When I run my application it does show up in the tool, but before long IE crashes. The tool works just fine when not being monitored. Between not finding the source code and crashing I've gotten nowhere.

Does the crash still happen if you use sampling, the least detailed mode of profiling? And do you get any error details when the crash happens, or are there any related errors in Event Viewer? Please let me know what you find!
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group