Red Gate forums :: View topic - Error: Could not find file SQLCompareSimpleHTMLReport.xsl
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Compare 10
SQL Compare 10 forum

Error: Could not find file SQLCompareSimpleHTMLReport.xsl

Search in SQL Compare 10 forum
Post new topic   Reply to topic
Jump to:  
Author Message
Barney1942



Joined: 13 Mar 2014
Posts: 1

PostPosted: Thu Mar 13, 2014 12:09 pm    Post subject: Error: Could not find file SQLCompareSimpleHTMLReport.xsl Reply with quote

Hi,

I am evaluating this product to see if it servers our needs following an error where our Prod, Test, Stage and Dev environments became out of sync.

I was under the impression that you only need the "SQL Automation Pack" to run compares from the command line and the full SQL Compare 10 can be used to create projects. I therefore have both installed on my laptop, but if we use this option the SQL AP will be on a single centralized server and Compare will be on each Developers laptop.

I have a command line which works and reads a project and returns an output, most excellent and was again under the impression I just needed to take the CL and run it under SQL Automation Pack.

CL : "SQLCompare.exe /project:"C:\xxxxxx\DEV v PROD.scp" /verbose /rad /report:c:\temp\report.html /reportType:Simple"

and then I tried to run it in

C:\Program Files (x86)\Red Gate\SQL Compare 10>
C:\Program Files (x86)\Red Gate\SQL Automation Pack 1\sqlCI\SC>

in directory 1 - no problem
in directory 2 - "Error: Could not find file 'C:\Program Files (x86)\Red Gate\SQL Automation Pack 1\sqlCI\SC\SQLCompareSimpleHTMLReport.xsl'."

Am I making a schoolboy error here??
Have I missed something obvious??

Forums and Wiki checked and nothing obvious.

Cheers

Barney
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6677

PostPosted: Mon Mar 17, 2014 11:08 am    Post subject: Reply with quote

Hi Barney,

I think the best thing for now would be to copy all of the .XSL files from the SQL Compare 10 installation folder to the automation pack folder. that should fix the problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group