Red Gate forums :: View topic - Custom metric does not collect data
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Monitor 3
SQL Monitor 3 forum

Custom metric does not collect data

Search in SQL Monitor 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
darshanshah



Joined: 16 Oct 2013
Posts: 3
Location: India

PostPosted: Wed Oct 16, 2013 3:32 pm    Post subject: Custom metric does not collect data Reply with quote

I have created one custom metric. Which is working properly for server A but not working for another server B.
Not getting any error for that . When I checked the data for server B and custom metric in Cluster_SqlServer_Database_Keys ,however no data found for server B. on this server before maintenance window was set. I have removed it still it is not working.
If I'm making new metric for server B then again it is not working.

I just got one monitoring alert.
Monitoring error (SQL Server data collection)

Can any body have any idea?
Back to top
View user's profile Send private message
priyasinha



Joined: 03 Jan 2007
Posts: 531

PostPosted: Wed Oct 16, 2013 4:26 pm    Post subject: Reply with quote

Hi,

Can you go to Configuration > Monitored servers page? Then click 'Show log' against this SQL Server to see the error message. Alternatively, you can also try 'Test metric collection' for this custom metric for this particular server.

Thanks,
Priya
Back to top
View user's profile Send private message
darshanshah



Joined: 16 Oct 2013
Posts: 3
Location: India

PostPosted: Thu Oct 17, 2013 6:57 am    Post subject: Reply with quote

Hi Priya,
there is no any error.

I observerd that If I change data collection frequency from 1 to 5 minutes than custom metric starts collecting data. and on analysis page it is showing data. but if I do reverse process then it is not working.
Back to top
View user's profile Send private message
priyasinha



Joined: 03 Jan 2007
Posts: 531

PostPosted: Thu Oct 17, 2013 11:44 am    Post subject: Reply with quote

Hi,

Looks like it needs more investigation. Can you please get in touch with support at support@red-gate.com?

Thanks,
Priya
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group