Red Gate forums :: View topic - Problem profiling WCF Service on IIS
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 8
ANTS Performance Profiler 8 forum

Problem profiling WCF Service on IIS

Search in ANTS Performance Profiler 8 forum
Post new topic   Reply to topic
Jump to:  
Author Message
Spx



Joined: 29 May 2013
Posts: 2

PostPosted: Wed May 29, 2013 4:25 pm    Post subject: Problem profiling WCF Service on IIS Reply with quote

Hi,

I have a problem when I try to profile my WCF Service hosted on IIS.
I tried what is describe on the following page : http://documentation.red-gate.com/display/APP80/Profiling+WCF+applications

The profiler doesn't profile anything and, after some time, I get the following error : "Failed to connect to target process because an exception occured : Could not start IIS
Caused by:
Timed out waiting for port 8013 on 127.0.0.1 to become available".

I don't understand why as this port is not used by any other applications. I tried with other ports with no more success. Everytime, IIS was already started before launching the profiling session.

I used to be able to profile this service with ANTS Performance v7 without any trouble.

Is there any changes since the v7 on that part ?
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 591

PostPosted: Thu May 30, 2013 6:47 pm    Post subject: Reply with quote

profiling in IIS is a little bit of a minefield. I usually recommend bypassing the issue and trying another technique - such as 'attach to process'.

Is this process >= .net 4?
Back to top
View user's profile Send private message
dene.boulton



Joined: 12 Oct 2011
Posts: 53
Location: Cambridge

PostPosted: Mon Jun 03, 2013 3:44 pm    Post subject: Reply with quote

Hello,

If this is still an issue could you please try the following:

1. Profile the application with version 7 of the Profiler and feedback to us if this works still or not. If not how does it fail. If it works what minor version are you using please.

If you no longer have it installed you will first need to uninstall v8 (after which you can install v8 side-by-side with v7).

2. If you are able to, please send me a copy of your IIS applicationHost.config - using the email button for my forum profile.

If you no longer have an installer for APP7 you can get one here:
http://documentation.red-gate.com/display/APP80/Release+notes+and+other+versions

Thank you.
_________________
Dene Boulton
Red Gate
Back to top
View user's profile Send private message Send e-mail
Spx



Joined: 29 May 2013
Posts: 2

PostPosted: Fri Jun 07, 2013 2:34 pm    Post subject: Reply with quote

'Attach to process' worked but I wanted line-by-line profiling that is not working with this mode.

I will try with v7 soon (doesn't have time to test it for now).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group