Red Gate forums :: View topic - SSMS 2012 Error
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Search 1
SQL Search 1 forum

SSMS 2012 Error

Search in SQL Search 1 forum
Post new topic   Reply to topic
Jump to:  
Go to page 1, 2  Next
Author Message
QuentinS



Joined: 14 May 2012
Posts: 2

PostPosted: Mon May 14, 2012 1:56 am    Post subject: SSMS 2012 Error Reply with quote

Hi,

I recently installed SQL Server 2012 and have started using SSMS 2012 for all my development. I reinstalled SQL Search 1.1.6.1 but whenever I start SQL Search and whenever I type something in the search box it comes up with an error message from the web browser control that displays the ads -

Cannot find ...:/Users/Q/AppData/Local/Red%2520Gate/SQLSearch%25201/Ads/3.mht?e98e50.... etc
Make sure the path or Internet address is correct.


That path does exist. I thought it might be a permissions issue so I gave that Ads folder full permissions for Everyone.
No joy.

It looks like it's inserting an extra 25 after the %.
If I paste it into a browser it says the same thing (not found) but if I remove the 25 after the % (and just have %20) it works.

Any help would be appreciated because it is making SQL Search virtually unusable.
Back to top
View user's profile Send private message
Yelnoc4



Joined: 21 May 2012
Posts: 1

PostPosted: Mon May 21, 2012 6:17 pm    Post subject: Reply with quote

QuentinS -- I just had the same problem and was able to resolve it.

I had moved my User folders to my E: drive. I looked at my C: drive and found the Red Gate folder there. I then copied it to my E: drive and it looks like all is well. At least, I don't get the error.

I don't know if you have the same situation, but it looks like the install program doesn't ask Windows for the User folder location, but the app does.
Back to top
View user's profile Send private message
QuentinS



Joined: 14 May 2012
Posts: 2

PostPosted: Tue May 22, 2012 4:50 am    Post subject: Reply with quote

My AppData is in the usual place.
The issue is that the SQL Search HTML control that shows the ads is treating the URL space (%20) as a literal part of the address and converting the % to a URL % (%25) -

/Red Gate/SQLSearch 1/Ads/...

should get converted to

/Red%20Gate/SQLSearch%201/Ads/...

but it's getting converted to this -

/Red%2520Gate/SQLSearch%25201/Ads/...

It looks like it's getting converted twice and the second time it treats the converted URL as an unconverted URL.
I'm wondering if it's a .Net thing. I've got .Net 4.5 beta installed.

Anyone? Bueller?
Back to top
View user's profile Send private message
greg_burns



Joined: 22 Sep 2005
Posts: 9

PostPosted: Wed Jun 06, 2012 8:44 pm    Post subject: Reply with quote

I just ran into this error myself today. I am also running SSMS 2012.

I had also just installed VS 2012 RC...
Back to top
View user's profile Send private message
pretzelfisch



Joined: 15 Nov 2005
Posts: 1

PostPosted: Thu Jun 07, 2012 7:42 pm    Post subject: Reply with quote

I am seeing this as well only with ssms 2012 ssms 2008 works fine still. I also have vs 2012rc installed
Back to top
View user's profile Send private message
curtmiller66



Joined: 05 Jul 2012
Posts: 2
Location: Issaquah, WA

PostPosted: Thu Jul 05, 2012 7:46 pm    Post subject: Reply with quote

Clean machine, clean install of VS 2012 RC, SQL Server 2012 and SQL Search 1.1.6.1 and I run into the same issue. My user directory is D:\Curt and the managled name is missing the drive letter and has the spaces URL encoded twice. It does make the product rather annoying to use. 1.5 months after initial report and no fix. They are usually better than this.
Back to top
View user's profile Send private message
Manfred.Castro



Joined: 23 Apr 2012
Posts: 205

PostPosted: Mon Jul 16, 2012 7:45 pm    Post subject: Reply with quote

We believe the issue to be caused by .NET Framework 4.5.
Unfortunately .NET Framework 4.5 is not currently supported.
I have notified development of the issue and it has been assigned the internal reference number of SDI-515.
_________________
Manfred Castro
Product Support
Red Gate Software
Back to top
View user's profile Send private message
dmullen99



Joined: 16 Aug 2012
Posts: 1

PostPosted: Thu Aug 16, 2012 7:55 am    Post subject: Reply with quote

Wow, a month goes by with no update? On my system SQL Search is not functional at all with that error popping up with every keystroke. Redgate, there's supporting .net 4.5 and being able to co-exist with it.

It took me all of 5 minutes to figure out the root problem and a workaround. It'd be nice if someone at Redgate could take a few minutes and do the same but whatever. It appears to me to be caused by the path being double encoded as %25 is "%" so encoding the space made a %20, encoding that made a %2520

If anyone else has this problem, I was able to get around it by making a copy of the AppData\Local\Red Gate directory and calling it Red%20Gate. Then, inside that directory rename the SQLSearch 1 directory to SQLSearch%201. Might be an issue with the other directories in there as well but I haven't noticed anything (yet.) Hope that helps...
Back to top
View user's profile Send private message
NullThought



Joined: 20 Aug 2012
Posts: 2

PostPosted: Mon Aug 20, 2012 3:53 pm    Post subject: make sure the path or Internet address is correct. Reply with quote

I fequently use and recommend Red-Gate SQL Search. It is now broken with the error in the title.

Previous posts link this to .NET 4.5 . .NET 4.5 and VS 2012 are now production. My expectation is that a first tier tool company supports released tools.

When does Red-Gate intend to update its tool set to support released MS development tools?
Back to top
View user's profile Send private message
NullThought



Joined: 20 Aug 2012
Posts: 2

PostPosted: Mon Aug 20, 2012 7:27 pm    Post subject: Thanks to dmullen99 Reply with quote

My thanks to dmullen99. Implemented the work around discussed and am able to now use Search.
Back to top
View user's profile Send private message
duhnbr



Joined: 10 Mar 2006
Posts: 10
Location: Earth

PostPosted: Thu Aug 23, 2012 10:57 pm    Post subject: Ditto on the thanks to dmullen99 !!! :D Reply with quote

Ditto on the thanks to dmullen99 !!! Very Happy
_________________
SQL PROCtologist
Back to top
View user's profile Send private message
JamesPlaistere



Joined: 12 Sep 2012
Posts: 2
Location: Hove

PostPosted: Wed Sep 12, 2012 12:23 pm    Post subject: Re: Reply with quote

dmullen99 wrote:
Wow, a month goes by with no update? On my system SQL Search is not functional at all with that error popping up with every keystroke. Redgate, there's supporting .net 4.5 and being able to co-exist with it.

It took me all of 5 minutes to figure out the root problem and a workaround. It'd be nice if someone at Redgate could take a few minutes and do the same but whatever. It appears to me to be caused by the path being double encoded as %25 is "%" so encoding the space made a %20, encoding that made a %2520

If anyone else has this problem, I was able to get around it by making a copy of the AppData\Local\Red Gate directory and calling it Red%20Gate. Then, inside that directory rename the SQLSearch 1 directory to SQLSearch%201. Might be an issue with the other directories in there as well but I haven't noticed anything (yet.) Hope that helps...


The workaround above did not work for me, so I used a sledgehammer to fix it as I was still getting errors regarding the advert .mht files being missing.

So once Sql Search is installed on your SQL 2012 environment copy the

\AppData\Local\Red Gate

folder in your username directory, and make a folder at

\AppData\Local\Red%20Gate with all of the contents within.

Then make another copy of the same folder at

\AppData\Local\Red%2520Gate

Try using the search a few times and let it keep erroring (just OK them), it will generate 5 files:

1.mht
2.mht
3.mht
4.mht
Default.mht

in \AppData\Local\Red Gate\SQLSearch 1\Ads

copy these files to both Ads folders in the copied folders you created above.

The \AppData\Local\Red%20Gate folder may not be needed but I didn't have the time to check. 10 minutes messing around is enough Smile Hope this helps.
Back to top
View user's profile Send private message
JamesPlaistere



Joined: 12 Sep 2012
Posts: 2
Location: Hove

PostPosted: Wed Sep 12, 2012 12:27 pm    Post subject: Reply with quote

I forgot to add don't forget to change the directory names for SQLSearch 1 directory to SQLSearch%201 and SQLSearch%25201 respectively. Cheers.
Back to top
View user's profile Send private message
jstark



Joined: 13 Sep 2012
Posts: 1

PostPosted: Thu Sep 13, 2012 1:35 pm    Post subject: Reply with quote

I'm also experiencing this after installing VS2012. However, since my user login has spaces in it none of the workarounds are viable. Any news on fixing this issue?
Back to top
View user's profile Send private message
Tahmoh



Joined: 27 Sep 2012
Posts: 1
Location: St. Paul, MN

PostPosted: Thu Sep 27, 2012 4:00 pm    Post subject: Reply with quote

Thanks dmullen99 your solution worked perfectly. I'm in SQL 2012 .Net 4.5
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Go to page 1, 2  Next
Page 1 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group