Red Gate forums :: View topic - Profiling in SharePoint 2010
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 6
ANTS Performance Profiler 6 forum

Profiling in SharePoint 2010

Search in ANTS Performance Profiler 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
ShareOne



Joined: 25 Apr 2012
Posts: 4

PostPosted: Wed Apr 25, 2012 2:27 pm    Post subject: Profiling in SharePoint 2010 Reply with quote

For profiling in SP 2010 i did al these steps:

http://www.21apps.com/sharepoint/code-profiling-ants/

But now when i click Start Profiling, I don't ssee anything, and left in the bottom i see a status on waiting and nothing happens.
Except a IE browser appears with page not found. Whe I look in IIS the Site of the web application has been stopped. When I start de site again nothing is happening still.

What did I do wrong?
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1144
Location: My desk.

PostPosted: Wed Apr 25, 2012 3:23 pm    Post subject: Reply with quote

Thanks for your post- profiling Sharepoint can be a little tricky to get going sometimes as there's a whole host of permissions and configuration hurdles that may cause it to fail.
A good getting started guide is here, and we also have an article detailing troubleshooting steps you can take, here

If you're still having trouble, then we may need logfiles to see if they give any further clues- you can mail these over to support@red-gate.com quoting F0059572 in the subject line.
Back to top
View user's profile Send private message
ShareOne



Joined: 25 Apr 2012
Posts: 4

PostPosted: Wed Apr 25, 2012 3:39 pm    Post subject: Reply with quote

I did what was told there but the web site opens and it stays empty. When I go to IIS MAnager I see that the web site is stopped.

Here is a link to the screencast of the problem.

http://screencast.com/t/U66JqxqhADR
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1144
Location: My desk.

PostPosted: Wed Apr 25, 2012 3:48 pm    Post subject: Reply with quote

Thanks.
So you're telling to profile on the original port; this should stop the site then launch it's own copy. Because it says the port is in use when you try to manually start it, it would appear the profiler site has started but the profiler cannot connect to it.
We'd next need to check the logs - you'll find the option in the help menu.
Please send these over as per my earlier post.

I also noticed you had some other sites listed- does it make any difference if you stop all those first?
Back to top
View user's profile Send private message
dene.boulton



Joined: 12 Oct 2011
Posts: 53
Location: Cambridge

PostPosted: Wed Apr 25, 2012 4:08 pm    Post subject: Reply with quote

Users of ANTS PP v6 can also try to make use of this workaround that is outlined here for AMP: http://www.red-gate.com/supportcenter/content/ANTS_Memory_Profiler/knowledgebase/amp_sharepoint_2010

However, this is by no means fool proof.

ANTS PP v7 does have dedicated support for SharePoint 2010.
_________________
Dene Boulton
Red Gate
Back to top
View user's profile Send private message Send e-mail
ShareOne



Joined: 25 Apr 2012
Posts: 4

PostPosted: Thu Apr 26, 2012 7:04 am    Post subject: Reply with quote

I will try version 7
Back to top
View user's profile Send private message
ShareOne



Joined: 25 Apr 2012
Posts: 4

PostPosted: Thu Apr 26, 2012 9:05 am    Post subject: Reply with quote

Version 7 works perfectly, thanks!
Back to top
View user's profile Send private message
dene.boulton



Joined: 12 Oct 2011
Posts: 53
Location: Cambridge

PostPosted: Thu Apr 26, 2012 9:50 am    Post subject: Reply with quote

No problem, glad it solved this for you.
I should of also pointed out that ANTS Memory Profiler 7.4 also supports SharePoint 2010 too.
_________________
Dene Boulton
Red Gate
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group