Red Gate forums :: View topic - Installing Database Packages fails on 64bit Vista
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Comparison SDK Previous Versions
SQL Comparison SDK Previous Versions forum

Installing Database Packages fails on 64bit Vista

Search in SQL Comparison SDK Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
atoth



Joined: 24 Feb 2006
Posts: 6

PostPosted: Thu Jun 04, 2009 1:21 pm    Post subject: Installing Database Packages fails on 64bit Vista Reply with quote

If you attempt to install the Sample Databases from the SDK 8 getting started application, you get an error :

"Could not load ..SubPackage.WidgetDev.exe' or one of its dependencies. An attempt was made to load a program with an incorrect format."

I guess your .net assembly has chosen to run in 64bit but is referencing a 32bit dll?

Adam
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6580

PostPosted: Thu Jun 04, 2009 5:26 pm    Post subject: Reply with quote

Hi Adam,

Most of the time, you can compile an SDK project as 64-bit or "any CPU". There is only one exception I know of, and that is when the RedGate.BackupReader.dll is referenced in the project. That dll is x86 only and will result in an invalid format exception if you reference it inside any project being compiled for "any CPU".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group