Red Gate forums :: View topic - Can't Connect to Local SQl Server instance
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

Can't Connect to Local SQl Server instance

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Author Message
seanpbrown



Joined: 30 Dec 2013
Posts: 1

PostPosted: Mon Dec 30, 2013 10:52 pm    Post subject: Can't Connect to Local SQl Server instance Reply with quote

Hello,

I recently downloaded deployment manager starter edition to see if it is something that we want to use. I installed it locally, and am trying to add a local sql server instance as a target. I keep getting an error "System.Data.SqlClient.SqlException (0x80131904): Login failed for user 'svc_Deployment'". Sounds like I didn't set up the user correctly in the local db, but I set up the exact same user on one of our actual development servers, and I can connect to that server just fine. It seems like maybe there is something different about pointing deployment manager to a local db that I am not getting. The only thing I noticed in the requirements page is I needed to turn on named pipes on the local db. ALso, I have not installed agents on either of my db instances. Thanks!
Back to top
View user's profile Send private message
chirayu



Joined: 17 Sep 2012
Posts: 51

PostPosted: Tue Dec 31, 2013 2:18 pm    Post subject: Reply with quote

Which requirements page asked you to turn on named pipes for your local db? There is nothing different that you have to do to try to connect to do a local db.

Steps below show how I created a new user in my SQL Server local instance and connected to it via DM.

In SSMS, at the root level click on Security->Logins-> right-click to create new login and you are shown this pop up:


Then in Deployment Manager Environments page add a SQL Server target like so:


Health check succeeds for me. Could you let me know what you are doing different? If it still fails for you please do a manual health check (Environments -> Check health) and paste the log in this conversation. Thanks!
_________________
Chirayu Shishodiya
Software Engineer - Deployment Manager
Red Gate
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group