Red Gate forums :: View topic - Fail: "The specified path, file name, or both are too long"
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

Fail: "The specified path, file name, or both are too long"

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Author Message
isme



Joined: 12 Jun 2012
Posts: 74
Location: Edinburgh

PostPosted: Tue Nov 26, 2013 3:09 pm    Post subject: Fail: "The specified path, file name, or both are too long" Reply with quote

This morning we upgraded RGDM from version 2.3.2.1 to version 2.3.4.13.

After the upgrade my release failed to deploy because a path was too long.

Code:

2013-11-26 13:40:08 +00:00 INFO    - Agent version:     2.3.4.13
2013-11-26 13:40:08 +00:00 INFO   Installing package ApiServices-backend-database.0.82 from uploaded package cache into C:\Users\svc_deployment\AppData\Local\Temp\2apsnlzc.ep5\Packages\..\Applications\SSDVWUK1QPS602\ApiServices-backend-database\0.82
2013-11-26 13:40:09 +00:00 INFO   Installing 'ApiServices-backend-database 0.82'.
2013-11-26 13:40:09 +00:00 ERROR  The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.


The log doesn't show which path is too long. The path in the log is well under the 260 character limit.

The last release before the upgrade was successful.

Code:

2013-11-08 17:05:16 +00:00 INFO    - Agent version:     2.3.2.1
2013-11-08 17:05:16 +00:00 INFO   Installing package ApiServices-backend-database.0.54 from uploaded package cache into G:\RedaGate\PackageCache\ApiServices-backend-database.0.54\..\Applications\SSDVWUK1QPS602\ApiServices-backend-database\0.54
2013-11-08 17:05:16 +00:00 INFO   Installing 'ApiServices-backend-database 0.54'.
2013-11-08 17:05:17 +00:00 INFO   Successfully installed 'ApiServices-backend-database 0.54'.


It appears the new version is now using the TEMP environment variable of the service account (svc_deployment) as the installation path instead of the package cache directory (G:\RedaGate).

We changed TEMP for svc_deployment to something shorter: G:\Temp.

Now the package installation succeeds.

Code:

2013-11-26 13:43:13 +00:00 INFO    - Agent version:     2.3.4.13
2013-11-26 13:43:13 +00:00 INFO   Installing package ApiServices-backend-database.0.82 from uploaded package cache into G:\Temp\3uobdlq4.v5r\Packages\..\Applications\SSDVWUK1QPS602\ApiServices-backend-database\0.82
2013-11-26 13:43:13 +00:00 INFO   Installing 'ApiServices-backend-database 0.82'.
2013-11-26 13:43:14 +00:00 INFO   Successfully installed 'ApiServices-backend-database 0.82'


This change is not in the RGDM release notes. Can someone from Red Gate confirm the new behavior?
Back to top
View user's profile Send private message
DavidSimner



Joined: 04 Feb 2010
Posts: 49

PostPosted: Tue Nov 26, 2013 3:29 pm    Post subject: Reply with quote

Sorry! 2.3.4.13 contains this bug fix:

"Improved support for deploying multiple databases as part of the same step"

We didn't go into detail in the release notes as to what the bug was, or indeed, how we fixed it. Basically, all the deployments for a single step were being run from the same folder, so they clashed with each other. Our bug fix was to give each deployment its own folder in temp, rather than them all using the same folder, which is the behaviour that you are now seeing.

I'm glad to hear that you're back up and running again with the workaround. Is that going to be fine for you long-term, or are you after anything from us?
Back to top
View user's profile Send private message
isme



Joined: 12 Jun 2012
Posts: 74
Location: Edinburgh

PostPosted: Tue Nov 26, 2013 3:50 pm    Post subject: Reply with quote

Thanks for the quick reply!

The workaround should be acceptable as long as RGDM is the only service that uses the svc_deployment account.

The new dependency on TEMP should be added to the interface and documentation.

The Server Tools interface was the first place we looked to investigate the problem, but it didn't reveal anything.

Would you be able to make the working directory settable from within the RGDM Server Tools interface? The value of the setting could default to %TEMP%.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group