Red Gate forums :: View topic - DM does not point the Virtual Directory to physical path
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

DM does not point the Virtual Directory to physical path

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Author Message
rjayakumar



Joined: 21 Aug 2013
Posts: 8
Location: Bangalore

PostPosted: Wed Aug 21, 2013 7:55 am    Post subject: DM does not point the Virtual Directory to physical path Reply with quote

I am trying to use physical path to deploy as
x:\AppName_$(RedGateReleaseNumber) and DM though created the physical folder - it failed to point the properties of virtual directory to the newly created folder.

I am missing any other setting?

The other settings are as below

RedGateCreateWebSiteOnPort - 80
RedGateNotAWebSite - True
RedGatePurgePackageDirectoryBeforeCopy - True
RedGateWebSiteName - Default Web Site/AppName
_________________
________
Cheers,
Raghunandan
Back to top
View user's profile Send private message Send e-mail
Mike Upton



Joined: 11 May 2011
Posts: 108
Location: Red Gate

PostPosted: Wed Aug 21, 2013 3:19 pm    Post subject: Reply with quote

Hi,

I've already replied to your support e-mail about this, but for the benefit of any others who might be reading this...

Deployment Manager will not update the virtual directory setting in IIS if the RedGateNotAWebSite variable is set to true, because the purpose of the RedGateNotAWebSite variable is to disable any IIS configuration. The documentation about the various RedGateXXX variables is available here.
_________________
Mike Upton

Software Engineer
Red Gate Software Ltd.
Back to top
View user's profile Send private message
rjayakumar



Joined: 21 Aug 2013
Posts: 8
Location: Bangalore

PostPosted: Fri Aug 23, 2013 8:51 am    Post subject: Reply with quote

Thanks Mike.

I have set the variable to False and its working as expected now.

The reason for setting the value as TRUE was the naming used - when the parameter reads NotAWebSite --- it meant as virtual directory and hence it was set as True. Smile
_________________
________
Cheers,
Raghunandan
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group