Red Gate forums :: View topic - ERASEFILES & ERASEFILES_REMOTE ignored
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Backup 7
SQL Backup 7 forum

ERASEFILES & ERASEFILES_REMOTE ignored

Search in SQL Backup 7 forum
Post new topic   Reply to topic
Jump to:  
Author Message
oderks



Joined: 30 Jul 2008
Posts: 46

PostPosted: Wed Apr 03, 2013 9:09 am    Post subject: ERASEFILES & ERASEFILES_REMOTE ignored Reply with quote

I have this very awkward situation on our new cluster that my jobs seem to ignore ERASEFILES & ERASEFILES_REMOTE.

The result is having backup disks running full quickly with all effects and work coming with it.

I usually use BACKUP DATABASES [*] and BACKUP LOGS [*] with the ERASEFILES & ERASEFILES_REMOTE options.

The log also Always states something like this at the bottom:
4/3/2013 3:15:16 AM: The backup set on file 1 is valid.
--------------------------------------------------------------------------------
4/3/2013 3:15:16 AM: Deleting old backup file: H:\Backup\databasename\FULL_INSTANCENAME_databasename_20130401_031500.sqb
4/3/2013 3:15:16 AM: Deleting old backup file: \\networkname\directories\INSTANCENAME\databasename\FULL_INSTANCENAME_databasename_20130319_031500.sqb
4/3/2013 3:15:24 AM: Copied H:\Backup\databasename\FULL_INSTANCENAME_databasename_20130403_031500.sqb to \\networkname\directories\INSTANCENAME\databasename\FULL_INSTANCENAME_databasename_20130403_031500.sqb.

But on the new cluster I completely miss this part..... Locally (erasefiles) as well as on the networkdrive copies (erasefiles_remote). I just continues with the next database.

Now I must say that the old part is running version 6 something
The new cluster is running SQL Backup version 7.2.1.82 & Service application version 7.2.1.82
I already notice that the copy action is now a seperate action as I receive seperate emails from the copy to network action on success.
But I really need ERASEFILES & ERASEFILES_REMOTE to work! By default the FILEOPTIONS = 1 is not added when using the GUI. Also tried adding that, but to no avail.
Back to top
View user's profile Send private message
Anu Deshpande



Joined: 20 Apr 2009
Posts: 661
Location: Cambridge

PostPosted: Wed Apr 03, 2013 10:50 am    Post subject: Reply with quote

Many thanks for your post and apologies for inconvenience caused.

I have logged a support call for you call reference for which is F0071348.
_________________
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group