Red Gate forums :: View topic - Can't profile asp.net apps
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 6
ANTS Performance Profiler 6 forum

Can't profile asp.net apps

Search in ANTS Performance Profiler 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
mhanrahan



Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu Jun 16, 2011 4:34 pm    Post subject: Can't profile asp.net apps Reply with quote

Hi,

I just installed version 6.2.0.13 of ANTS Profiler and I am unable to profile any asp.net site. I have tried both ASP.NET FORMS and MVC 3 apps and neither work. When I click "Start Profiling" the profiler loads up IE, which gives a page not found error and the profiler itself says "The profiler did not find any methods with source code". Things I have tried so far are:

Started Profiling Using both Web Development Server and IIS
Created a bare bones ASP.NET Forms site that just has 'this.Title = "Test";' in the OnPageLoad event.
I have checked the .NET version (4.0 in all cases)
Used Process Explorer to ensure the environment variables "COR_PROFILER" and "COR_ENABLE_PROFILING" where set (which they were). Also I always see an info event in the event log which says ".NET Runtime version 4.0.30319.225 - The profiler was loaded successfully. Profiler CLSID: '{D6E0BA92-3BC3-45ff-B9CC-B4B5AB7190BC}'. "
I can profile console, windows forms and WPF apps without any problems.

The Web Development Server process (under profiling) itself doesn't seem to load .NET at all (it pretty much dies straight away..it took a few attempts to view its properties in Process Explorer!).

Any help or ideas would be greatly appreciated!

Many thanks,

Mike Hanrahan
Back to top
View user's profile Send private message
mhanrahan



Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu Jun 16, 2011 4:48 pm    Post subject: Reply with quote

Actually...just checked using Process Monitor and it does load .NET into the Web Development process. It didn't point to any other obvious problems however.

Mike Hanrahan.
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 546

PostPosted: Thu Jun 16, 2011 7:29 pm    Post subject: Reply with quote

Can you take a look at the windows application event log for .net errors?


Can you try running ANTS explicitly as administrator?
Back to top
View user's profile Send private message
mhanrahan



Joined: 16 Jun 2011
Posts: 5

PostPosted: Thu Jun 16, 2011 7:35 pm    Post subject: Reply with quote

Hi...there were no .net errors in the event log, but running explicitly as administrator worked. Weird, as previously I was getting the popup where I had to allow it to profile, so I assumed it had full admin privilages...but apparently not.

Anyway, its working now as administrator, so thanks!!

Mike.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group