Red Gate forums :: View topic - Microsoft Dynamics Ax Enterprise Portal cannot be profiled
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 5
ANTS Performance Profiler 5 forum

Microsoft Dynamics Ax Enterprise Portal cannot be profiled

Search in ANTS Performance Profiler 5 forum
Post new topic   Reply to topic
Jump to:  
Author Message
fallafab



Joined: 21 Apr 2010
Posts: 1

PostPosted: Wed Apr 21, 2010 2:37 am    Post subject: Microsoft Dynamics Ax Enterprise Portal cannot be profiled Reply with quote

Hi,

I'm trying to profile a Microsoft Dynamics Ax Enterprise Portal application and for some reason it doesn't work. If you are not familiar with Dynamics, here is how it works in a nutshell.
The enterprise portal I'm trying to profile is a Sharepoint application which uses what is called the "Microsoft Dynamics Ax .Net Business Connector" acting as a bridge between .Net and Dynamics Ax.
The problem is that when profiling, ANTS Performance Profiler seems to get in the way during the authentication process of the business connector (using NTLM authentication). Note that the authentication on SharePoint seems to be working fine. The error I'm getting in the event viewer is as follow:

Quote:
Dynamics Object Adapter Call failed.

CryptoAPI not available.
CryptoAPI not available.
Error executing code: CryptoAPI object not initialised.



(C)\Classes\CryptoAPI\salt
(C)\Classes\WebSession\clientCryptoInitializationVector - line 10
(C)\Classes\WebSession\parseArgs - line 98
(C)\Classes\WebSession\init - line 17


Microsoft.Dynamics.BusinessConnectorNet.BusinessConnectorException
at Microsoft.Dynamics.BusinessConnectorNet.AxaptaObject.Call(String methodName, Object[] paramList)
at Microsoft.Dynamics.Framework.BusinessConnector.Session.DynamicsObjectAdapter.Call(String methodName, Object[] paramList)


Is there any way I could exclude the Business Connector assembly from the profile? I don't really need to profile it as I can't change it anyway.

I'm using ANTS Performance Profiler 5.2 on Windows Vista (running as admin, UAC disabled) trying to profile Microsoft Dynamics Ax 2009 Enterprise Portal.

Thanks for your help
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6577

PostPosted: Thu Apr 22, 2010 10:39 am    Post subject: Reply with quote

Hello,

ANTS Performance Profiler attaches to a process, so it cannot discriminate between code that is part of different modules. The only caveat to this rule is that amount of "invasiveness" a module will trigger. For instance, when you profile with line-level detail, extra processing and code rewriting is done and sometimes this interferance causes problems.

You could try deleting the .pdb file for the assembly you don't want extra information about and see if that helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group