Red Gate forums :: View topic - Error: Unsupported column type - Empty
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

Error: Unsupported column type - Empty

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Go to page Previous  1, 2
Author Message
DavidSimner



Joined: 04 Feb 2010
Posts: 49

PostPosted: Tue Nov 26, 2013 12:47 pm    Post subject: Reply with quote

Cool :)

By scripts folder I mean whatever the build server checks out from source control.
Back to top
View user's profile Send private message
notbenjamin



Joined: 25 Sep 2013
Posts: 18

PostPosted: Tue Nov 26, 2013 2:32 pm    Post subject: Reply with quote

Cheers David

I've emailed them to you
Back to top
View user's profile Send private message
notbenjamin



Joined: 25 Sep 2013
Posts: 18

PostPosted: Tue Nov 26, 2013 4:12 pm    Post subject: Reply with quote

Hi David

I'm struggling a little with the second database that has this issue - I can't find any reference to sp_addtype in the packages or source control at all, yet I'm getting the same issue!

Code:
Error: Unsupported column type - Empty


Any ideas?
Back to top
View user's profile Send private message
DavidSimner



Joined: 04 Feb 2010
Posts: 49

PostPosted: Tue Nov 26, 2013 4:36 pm    Post subject: Reply with quote

Thanks for sending the files through. I've been able to reproduce the issue on SQL Compare version 10.3.8.406 (which from your copy/pasted output of TeamCity is the version you're using).

It looks like the issue is fixed in SQL Compare version 10.5.0.378, in that I can no longer reproduce it on that version.

If you upgrade the TeamCity plugin, it will mean you start using the latest version of SQL Compare. You can download it from: http://www.red-gate.com/dynamic/products/sql-development/sql-automation-pack/download (We now distribute the TeamCity plugin via the SQL Automation Pack, so once you've installed it, you can get to the newest version of the TeamCity plugin in the top-right corner of the "What's included?" page.)
Back to top
View user's profile Send private message
DavidSimner



Joined: 04 Feb 2010
Posts: 49

PostPosted: Tue Nov 26, 2013 4:39 pm    Post subject: Reply with quote

Let me know what happens with the second database after you've upgraded the plugin.

If it's still failing, then send me the snippet, and I'll tell you what files I need to debug that problem...
Back to top
View user's profile Send private message
notbenjamin



Joined: 25 Sep 2013
Posts: 18

PostPosted: Tue Nov 26, 2013 5:09 pm    Post subject: Reply with quote

Thanks David - has fixed it for the first database.

Still getting it on the second database

Code:
Generating creation script (45s)
[15:51:40][Generating creation script] Starting: E:\TeamCityBuildServer\buildAgent2\plugins\RedGateSQLServer\assets\SC\SQLCompare.exe /include="Identical" /include="StaticData" /scripts1="E:\TeamCityBuildAgent2\temp\buildTmp\hejhd3bz.yth\db\state" /o="default,ignoretSQLt" /scripts2="E:\TeamCityBuildAgent2\temp\buildTmp\x2vsp1m2.tyg" /scriptfile="E:\TeamCityBuildAgent2\temp\buildTmp\hejhd3bz.yth\db\CreationScript.sql" /abortOnWarnings="High"
[15:51:40][Generating creation script] Automation License: activated, edition: standard, serial number: 048-001-216039-419B
[15:51:40][Generating creation script] SQL Compare Command Line V10.5.0.378
[15:51:40][Generating creation script] ==============================================================================
[15:51:41][Generating creation script] Copyright ΒΈ Red Gate Software Ltd 1999-2013
[15:51:41][Generating creation script]
[15:51:41][Generating creation script] Registering data sources
[15:51:55][Generating creation script] Creating mappings
[15:51:55][Generating creation script] Comparing
[15:51:55][Generating creation script]
[15:51:55][Generating creation script] Applying Command Line Items
[15:51:55][Generating creation script]
[15:52:25][Generating creation script] Error: Unsupported column type - Empty
[15:52:26][Generating creation script] ##teamcity[buildStatus status='FAILURE' text='Generating creation script failed with exit code 126.  For generic information about this exit code, see: http://www.red-gate.com/sqlCI/ExitCodes/SQLCompare']
[15:52:26]sqlCI error occurred: RedGate.SQLCI.Engine.Error: Generating creation script failed with exit code 126.  For generic information about this exit code, see: http://www.red-gate.com/sqlCI/ExitCodes/SQLCompare
[15:52:26]A detailed error report will be sent to Red Gate.
[15:52:26]These reports go into our issue tracking system, and help us fix bugs.
[15:52:26]For information about what's contained in the report, see: http://redg.at/RY3TiS
[15:52:26]Sending error report to Red Gate: Preparing Report...
[15:52:26]Sending error report to Red Gate: Connecting to Server...
[15:52:29]Sending error report to Red Gate: Transferring...
[15:52:29]Sending error report to Red Gate: Finished.  Our reference number is: {6c102998-4ff9-46f9-bec3-e53d9259ba8c}
[15:52:29]Process exited with code -532462766
[15:52:29]Publishing internal artifacts
[15:52:29][Publishing internal artifacts] Sending build.finish.properties.gz file
[15:52:29]Build finished
Back to top
View user's profile Send private message
DavidSimner



Joined: 04 Feb 2010
Posts: 49

PostPosted: Tue Nov 26, 2013 6:41 pm    Post subject: Reply with quote

It's awesome to hear that it's now working on the first database :)

The second database is failing at the stage where it generates the creation script, so to debug it I only need a copy of the latest scripts folder (the thing TeamCity is checking out). If you email that across, then I can take a look at why it's not working.
Back to top
View user's profile Send private message
notbenjamin



Joined: 25 Sep 2013
Posts: 18

PostPosted: Wed Nov 27, 2013 11:23 am    Post subject: Reply with quote

Hi David

I've emailed it to you

Thanks for your continued help on this one!
Back to top
View user's profile Send private message
DavidSimner



Joined: 04 Feb 2010
Posts: 49

PostPosted: Wed Dec 04, 2013 10:32 am    Post subject: Reply with quote

For the sake of completeness of this forum thread.

We've followed up by email, and our internal reference for a static data table having a user-defined type as one of the fields of its primary key, i.e. the "Error: Unsupported column type - Empty" bug is SC-6650
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Go to page Previous  1, 2
Page 2 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group