Red Gate forums :: View topic - DM Publisher Error: API Key is Invalid (but key IS valid)??
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

DM Publisher Error: API Key is Invalid (but key IS valid)??

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Author Message
creatorbri



Joined: 16 Sep 2013
Posts: 4

PostPosted: Mon Sep 23, 2013 8:29 pm    Post subject: DM Publisher Error: API Key is Invalid (but key IS valid)?? Reply with quote

I'm trying to use the D.M. Application Publisher tool from within Visual Studio 2012 to package my Project.

On the first screen, the wizard has two fields -- "Deployment Manager URL" and "API Key for your Deployment Manager user account".

Initially, the URL field is pre-populated with the correct URL and port for our DM server, but the second field is pre-populated with the WRONG Profile API key. A red message at the bottom of the screen says "Could not connect to Deployment Manager". The API Key field has a red error message that says "Your API Key is invalid."

Naturally, I obtained the correct API Key for my profile from the Deployment Manager web interface and tried changing the value in the API Key field, but the same error messages appear.

I know that it must be connecting to DM, because if I change the URL or port, I get a different error on the URL field (such as a 404 error), and it doesn't even attempt to validate the API key field. But when I put in the correct URL, port, and key, I still just get the API Key invalid message.
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1123
Location: My desk.

PostPosted: Tue Sep 24, 2013 2:29 pm    Post subject: Reply with quote

Thanks for your post.

It sounds like you're doing everything correctly, so it's a little odd. The first thing I'd try is going into your profile page and generating a new API key:



If that still doesn't work, are you running VS under a different user account to the one you log into DM with? This shouldn't really matter AFAIK (for instance I'm running VS as administrator and DM as myself and it still works) but it /may/ be relevant...?

The VS Addin also creates a logfile in C:\Users\<your username>\AppData\Local\Red Gate\Deployment Manager VS Extension which could also be worth looking at (feel free to email support@red-gate.com if you'd rather not use the forum!)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group