Red Gate forums :: View topic - Test Search for Nuget packages times out
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

Test Search for Nuget packages times out

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Author Message
jtucker@inflexxion.com



Joined: 27 Jun 2013
Posts: 12
Location: Boston

PostPosted: Wed Jul 03, 2013 4:30 pm    Post subject: Test Search for Nuget packages times out Reply with quote

In Settings->Package Feeds->Test Action link anything I search for (including packages that I know are there), times out. Any ideas what is going wrong?
Back to top
View user's profile Send private message MSN Messenger
james.billings



Joined: 16 Jun 2010
Posts: 1117
Location: My desk.

PostPosted: Thu Jul 04, 2013 8:28 am    Post subject: Reply with quote

Can you try visiting the feed URL in a browser? You should see some XML output if it's online and working. If you're still having trouble, then what feed is it (i.e. the built in DM one / TeamCity / something else?)

A timeout would normally indicate either a communication problem to the machine in question or the required service isn't running.
Back to top
View user's profile Send private message
jtucker@inflexxion.com



Joined: 27 Jun 2013
Posts: 12
Location: Boston

PostPosted: Wed Jul 10, 2013 12:55 pm    Post subject: Follow-up on feed problem Reply with quote

I did visit the url and got the expected xml. It is the built-in feed from DM. It is still timing out. What is the name of the service? Is it a windows service?
Back to top
View user's profile Send private message MSN Messenger
jtucker@inflexxion.com



Joined: 27 Jun 2013
Posts: 12
Location: Boston

PostPosted: Wed Jul 10, 2013 1:00 pm    Post subject: but i did find this Reply with quote

I looked on the machine where the Nuget feed is installed. I do see the nuget virtual directory and it maps to e:\program files (x86)\Red Gate\Deployment Manager\NuGet. In the App_Data there is this error xml: <error time="2013-07-10T11:16:31.2402473Z" detail="System.IO.DirectoryNotFoundException: Could not find a part of the path 'E:\Program Files (x86)\Red Gate\Deployment Manager\NuGet'. at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath) at System.IO.FileSystemEnumerableIterator`1.CommonInit() at System.IO.FileSystemEnumerableIterator`1..ctor(String path, String originalUserPath, String searchPattern, SearchOption searchOption, SearchResultHandler`1 resultHandler, Boolean checkHost) at System.IO.Directory.EnumerateFiles(String path) at System.Web.WebPages.Deployment.PreApplicationStartCode.OnChanged(String key, Object value, CacheItemRemovedReason reason) at System.Web.Caching.CacheEntry.CallCacheItemRemovedCallback(CacheItemRemovedCallback callback, CacheItemRemovedReason reason)" source="mscorlib" message="Could not find a part of the path 'E:\Program Files (x86)\Red Gate\Deployment Manager\NuGet'." type="System.IO.DirectoryNotFoundException" host="ILBUILD02" errorId="c7152bff-b0ad-46c7-a23f-580e89c0fb0f"/>
Back to top
View user's profile Send private message MSN Messenger
james.billings



Joined: 16 Jun 2010
Posts: 1117
Location: My desk.

PostPosted: Wed Jul 10, 2013 2:38 pm    Post subject: Reply with quote

Is it perhaps permissions related then? So it doesn't have access to that folder?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group