Red Gate forums :: View topic - Issue with 7.3
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Backup 7
SQL Backup 7 forum

Issue with 7.3

Search in SQL Backup 7 forum
Post new topic   Reply to topic
Jump to:  
Author Message
smccreadie



Joined: 08 Apr 2013
Posts: 1

PostPosted: Mon Apr 08, 2013 2:52 pm    Post subject: Issue with 7.3 Reply with quote

We upgraded to 7.3 last week although even though we aren't using the cloud part.

The problem we're having is that it takes forever to show the activity history. I have 2 instances defined in the application. When I open it, it looks fine. If I expand the instance to show the databases, I get the spinny thing and takes 45 minutes plus to load the activity history. It's the same if I attempt to restore as the dialog takes the same amount of time to display what can be restored.

There's only 20 databases on the one instance I was working with. It never took this long before the upgrade. Any advice? Can we roll back to 7.2?
Back to top
View user's profile Send private message
Manfred.Castro



Joined: 23 Apr 2012
Posts: 205

PostPosted: Tue Apr 09, 2013 7:29 pm    Post subject: Reply with quote

Sorry you are experiencing this.
It appears you are running into a known issue with 7.3 and the activity history which has been reported by several users.
Some users have seen slightly increased performance by Reducing the amount of data in the activity cache.
http://www.red-gate.com/supportcenter/content/SQL_Backup/help/7.2/SBU_ActivityCacheLocation
This issue is currently under investigation and we plan to release a fix once one becomes available.

If you wish to downgrade to a previous version you can find the installer here.
ftp://support.red-gate.com/patches/SQLBackup/04Sep2012/SQLBackup_7.2.0.286.zip
_________________
Manfred Castro
Product Support
Red Gate Software
Back to top
View user's profile Send private message
noob2013



Joined: 30 Jan 2013
Posts: 19

PostPosted: Wed Apr 10, 2013 4:59 pm    Post subject: Reply with quote

I am trying to restore and experiencing the same issue. I have 3 instances defined and the spinning thing has been going for more than 30 minutes and still running once I click the Restore button.

I checked
http://www.red-gate.com/supportcenter/content/SQL_Backup/help/7.2/SBU_ActivityCacheLocation

as suggested and %LOCALAPPDATA%\Red Gate\SQL Backup\Server Data\localDataCache.dat is only 38KB and 1.dat-journal is only 11KB. These are the only 2 files that has today's date modified.
As for "Reducing the amount of data in the activity cache", we have a SQL job that deletes the server backup history that is older than 30 days.

I'm just glad I'm not trying to urgently restore this db. I'm glad it's a test restore to make sure the backup is good.

Just wondering if the spinning thing will ever stop and the activity history will actually come up? And if so, how long did it took?
Back to top
View user's profile Send private message
RBA



Joined: 05 Jun 2009
Posts: 148
Location: Cambridge

PostPosted: Wed Apr 10, 2013 5:30 pm    Post subject: Reply with quote

Hi,

We're looking into why the cache synchronisation is slow for a number of users. If you need to restore and the UI is unresponsive a t-sql script can be used instead.

If the green spinner completes, is it faster from then on or always slow on refresh? We were anticipating a slightly longer duration immediately after upgrade but not on every refresh. If its permanently slow, you can delete the local cache files on the workstation and the data.sdf on the server which will clear history information (the activity history will still show previous backups made using SQL Backup, but Red Gate specific additional information for old backups will be lost).

Regards,
_________________
Robin Anderson
Development
Red-Gate Software
Back to top
View user's profile Send private message Send e-mail
noob2013



Joined: 30 Jan 2013
Posts: 19

PostPosted: Wed Apr 10, 2013 5:39 pm    Post subject: Reply with quote

Quote:
If the green spinner completes, is it faster from then on or always slow on refresh?


No idea on speed as it is still spinning with "Retrieving backup history ...". I am beginning to think it's not going to show any history information.
Back to top
View user's profile Send private message
noob2013



Joined: 30 Jan 2013
Posts: 19

PostPosted: Thu Apr 11, 2013 9:02 pm    Post subject: Reply with quote

I do not meant to hijack smccreadie's thread. Sorry ... but thought I do a quick update.

The spinning green thing did not stop - waited till the end of yesterday and close out the app.
This morning launched SQL Backup again, and server starts spinning, so did Activity History. Waited for about an hour - it did not stop, so I close out the app.
Did not bother to try Restore or Backup. Doing it the old fashion tsql way. Unfortunately, until the fix for this issue, SQL Backup tool is pretty much useless to me now.
Back to top
View user's profile Send private message
RBA



Joined: 05 Jun 2009
Posts: 148
Location: Cambridge

PostPosted: Fri Apr 12, 2013 10:45 am    Post subject: Reply with quote

Hi,

Apologies that you are experiencing what I can appreciate is a very frustrating issue. We are investigating the causes of this behaviour; there are a couple pieces of information that will be useful to us to help diagnose and hopefully resolve this for you and others.

The SQL Backup UI logs its activity to:
C:\Users\USER.NAME\AppData\Local\Red Gate\Logs\SQL Backup
If you could email me the log created during the upgrade I can see which steps took the longest or didn't complete (if you can remember the date, otherwise please send all recent logs).

Also, there are UI cache files stored in
C:\Users\USER.NAME\AppData\Local\Red Gate\SQL Backup\Server Data
which I can examine. If you want, you can delete the files in this directly and the UI will sync history afresh - this could be speed things up if the cache is particularly fragmented due to the upgrade (the first load may slow, but once the history cache is written it should be faster next time).

If it is still slow, then please delete or rename the data.sdf file from the machine hosting SQL Server (C:\ProgramData\Red Gate\SQL Backup\Data\{INSTANCE}).

Wiping the data.sdf isn't really a fix, since you lose some of the details in the activity history, but if you are blocked then this may be the best option.

Regards,

Robin Anderson
Developer, SQL Backup
robin.anderson@red-gate.com
Back to top
View user's profile Send private message Send e-mail
Marianne



Joined: 03 Oct 2011
Posts: 45

PostPosted: Thu Apr 18, 2013 5:22 pm    Post subject: Reply with quote

Hi,

We have released a patch to address this issue, version 7.3.1.1. You can download this using Check for Updates (from the Help menu in the SQL Backup GUI) or by downloading the installer from the SQL Backup page.

If you have already upgraded to SQL Backup 7.3, you will not need to upgrade your server components again.

Thanks,

Marianne
_________________
Marianne Crowder
Red Gate Software Limited
Back to top
View user's profile Send private message
noob2013



Joined: 30 Jan 2013
Posts: 19

PostPosted: Fri Apr 19, 2013 3:45 pm    Post subject: Reply with quote

@ RBA
Sorry. Did not check back on the thread until today.

@Marianne
Thanks, installed and it seems to fix the issue for me. No more green spinning thing on server or restore button
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group