Red Gate forums :: View topic - Compatibility with 6.4
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Backup 7
SQL Backup 7 forum

Compatibility with 6.4

Search in SQL Backup 7 forum
Post new topic   Reply to topic
Jump to:  
Author Message
bdub0



Joined: 03 Apr 2013
Posts: 1

PostPosted: Wed Apr 03, 2013 7:27 pm    Post subject: Compatibility with 6.4 Reply with quote

Will it be possible to restore backups that are created with 7.3 with verion 6.4 of Redgate? We have several clients on various versions of Redgate and some are receiving the free upgrade notice. We need to know how to advise them.
Back to top
View user's profile Send private message
petey



Joined: 24 Apr 2005
Posts: 2276

PostPosted: Thu Apr 04, 2013 4:05 am    Post subject: Reply with quote

Backups created with 7.3 can be restored using 6.4, except when the backup created in 7.3 is encrypted with a unicode password.

E.g. this backup can be restored by 6.4

Code:
EXEC master..sqlbackup '-sql "BACKUP DATABASE model TO DISK = [<AUTO>] WITH PASSWORD = [password_value]"'

but this cannot be restored:

Code:
EXEC master..sqlbackup N'-sql "BACKUP DATABASE model TO DISK = [<AUTO>] WITH PASSWORD = [杨立文]"'

_________________
Peter Yeoh
SQL Backup Consultant Developer
Associate, Yohz Software
Beyond compression - SQL Backup goodies under the hood, updated for version 7
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group