Red Gate forums :: View topic - memory leak - webservices
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Memory Profiler 7
ANTS Memory Profiler 7 forum

memory leak - webservices

Search in ANTS Memory Profiler 7 forum
Post new topic   Reply to topic
Jump to:  
Author Message
ssteiner



Joined: 08 Oct 2012
Posts: 1

PostPosted: Mon Oct 08, 2012 3:04 pm    Post subject: memory leak - webservices Reply with quote

Hi

My service app (so no UI) seems to have a memory leak that I'm trying to get to the bottom of using ANTS.
If I take two snapshots, I see memory usage growing slowly but constantly. If I look at the class list and filter out new objects, at the very top I have strings, and if I look at what's in them, it seems they're all part of my web service wrapper class. The wrapper class talks to a bunch of webservices, and there's one wrapper per session (there's one for every logged in user, plus about a dozen administrative ones.. and every couple of minutes, I clone one of the existing ones to load some data from the third party system and compare with what I currently know about the system in my database).
What's in all those strings? I have names of the classes that are used to communicate with the webservices, namespaces for the webservices, etc. Also growing at a somewhat slower but still alarming rates are ElementAccessors, ElementMapping, and a lot of other classes that seem to be used by the webservices I'm talking to.

My wrapper makes use of a couple webserivces that are all added via "add service reference", and there's no explicit calls to Open/Close on each of those service references.

Now, I'm a bit puzzled as to why I see all those new object showing up every time I make a snapshot - am I missing something fundamental about web services, or is ANTS misleading me into going down a wrong path?
Back to top
View user's profile Send private message Send e-mail
jessica.ramos



Joined: 23 Apr 2012
Posts: 184

PostPosted: Wed Oct 10, 2012 12:34 am    Post subject: Reply with quote

Thanks for your post. Could you please send your results file to support@red-gate.com with "F0065482" in the subject line so we can take a look?
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group