Red Gate forums :: View topic - SQL Source Control stuck on 2/4: Determining latest Version
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Source Control 3
SQL Source Control 3 forum

SQL Source Control stuck on 2/4: Determining latest Version

Search in SQL Source Control 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
ddomanil



Joined: 24 Feb 2012
Posts: 2

PostPosted: Fri Feb 24, 2012 11:25 am    Post subject: SQL Source Control stuck on 2/4: Determining latest Version Reply with quote

Hi - I have SQL Compare linked to a DB server with SQL Server 2008 R2 db. It's currently linked to seven databases and 5 of them work correctly with SQL Compare 10.0.0.143.

The problem with the other two is that when I right-click > Commit Changest to Source Control, it starts thinking and gets up to 2/4: Determining latest version and it will sit there thinking without actually finishing determining what changes have occured. This does not happen with the other databases.

My machine is running 64-bit Windows 7. My colleague next to me is running 64-bit XP and his SQL Compare works well.
Back to top
View user's profile Send private message
ddomanil



Joined: 24 Feb 2012
Posts: 2

PostPosted: Fri Feb 24, 2012 11:53 am    Post subject: Reply with quote

My mistake, it is SQL Source Control and the version I'm running is 3.0.4.40
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6581

PostPosted: Mon Feb 27, 2012 3:36 pm    Post subject: Reply with quote

Because of the lack of error information presented, we have been simply suggesting that you unlink and re-link to the database if this happens. If that doesn't help, we can have a try at debugging it.

Please let me know if you need the instructions for that and I can email you about it.
Back to top
View user's profile Send private message
shiftbit



Joined: 06 Mar 2013
Posts: 9

PostPosted: Thu Mar 07, 2013 9:40 pm    Post subject: Reply with quote

I am having the same problem. I have a local instance that was linked to a path in a subversion repository. After committing the changes in to this branch, I unlink and pointed it to a different location. When starting, it gets stuck at 10% and goes no further.


note: I had originally pointed the link to trunk, because I had used sql compare to bring down all the differences between our production db and my local instance. Then I committed these into trunk for a starting point.
Then I branched this into a new branch. This new branch is what I am trying to link to.
Back to top
View user's profile Send private message
Manfred.Castro



Joined: 23 Apr 2012
Posts: 205

PostPosted: Fri Mar 08, 2013 6:19 pm    Post subject: Reply with quote

What version of the tool are you on?
Can you try updating to the latest available version to see if the issue persists?
If you continue to experience your issue can you let it run at the point it gets stuck for a couple minutes and then send us the log file located here.
C:\Users\<username>\AppData\Local\Red Gate\Logs\SQL Source Control 3
You can email the log file to support@red-gate.com
Please include your supprt reference number F0070484 in the subject header.
_________________
Manfred Castro
Product Support
Red Gate Software
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group