Red Gate forums :: View topic - Unable to profile Web Development Server - server shuts down
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 6
ANTS Performance Profiler 6 forum

Unable to profile Web Development Server - server shuts down

Search in ANTS Performance Profiler 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
mark_crystalsoft



Joined: 11 Jan 2012
Posts: 2
Location: Melbourne, Australia

PostPosted: Wed Jan 11, 2012 2:18 am    Post subject: Unable to profile Web Development Server - server shuts down Reply with quote

Hi,

I installed version 6.3 of the performance profiler this morning. I also installed the Visual Studio plugin.
I am trying to profile a .NET 3.5 web site on my machine using Visual Studio 2010 Pro (x64) running on Windows 7 Pro.

I can't even get the most basic profiling to work.

When I start the profiler I choose:
- ASP.NET web application (web development server)
- In the web application path I put the full path to my root web folder (which contains my default.aspx)
- In the web server virtual directory I put in /wwwroot (I have also tried just /)
- In the port I have chosen 50103
- In .NET version I have .NET 2

When I normally run the application in the debugger the site loads as http://localhost:50102/wwwroot/ so the settings I chose above mimic this closely enough.

When I try to 'Start Profiling' a few things happen:
- The profiler seems to start
- A new instance of the ASP.NET development server starts up but then seems to shut down straight away without any obvious error
- The IE window which starts up starts up with the url http://localhost:50103/wwwroot and I get an error stating "Internet Explorer cannot display the webpage"


I have spent a couple of hours trying to diagnose this, looking through the forums and other site from Google but I can't seem to find what is going wrong.

If I am doing something stupid I apologise but I am about to give up on this as right now I am totally blocked trying to do the most basic of tasks.
I would appreciate any help.

Thanks

Mark
_________________
Mark Rodrigues
Crystal Software Solutions Pty Ltd
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6582

PostPosted: Wed Jan 11, 2012 12:38 pm    Post subject: Reply with quote

Hi Mark,

Since this problem is so common and so difficult to solve because of the complete lack of feedback by either Profiler or devserver, you are probably going to find a lot of unhelpful, contradictory, or irrelevant information on the Red Gate website with regards to fixing it.

But typically, either running ANTS Performance Profiler as administrator or disabling Internet Explorer's protected mode fixes this 50% of the time these days.
Back to top
View user's profile Send private message
mark_crystalsoft



Joined: 11 Jan 2012
Posts: 2
Location: Melbourne, Australia

PostPosted: Thu Jan 12, 2012 12:28 pm    Post subject: Reply with quote

Hi Brian,

Thanks for the help.

It turns out running the profile as administrator fixed the problem.

On Windows 7, I wasn't given the right-click option to 'Run as Administator' but I found that I had to edit the properties of the icon and click 'Run as Administrator' in the property box to get this to work.

Thanks again.

Mark
_________________
Mark Rodrigues
Crystal Software Solutions Pty Ltd
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6582

PostPosted: Thu Jan 12, 2012 12:38 pm    Post subject: Reply with quote

Hi Mark,
ANTS Performance Profiler is designed in a way that it should prompt automatically for elevation when needed. However, it's not working sometimes, sorry to say.

Usually a shift+right-click will allow you to force a run as administrator.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group