Red Gate forums :: View topic - Restore from file problem
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Backup Previous Versions
SQL Backup Previous Versions forum

Restore from file problem

Search in SQL Backup Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
daveh



Joined: 24 Apr 2008
Posts: 2

PostPosted: Thu Apr 24, 2008 11:07 pm    Post subject: Restore from file problem Reply with quote

I have a roughly 2.7 GB backup of a database that was performed on one SQL Server which I have then copied to another SQL Server to restore. When load it in using the restore wizard the there is a small red x in the OK column. When I hold my mouse over this x the message, Could not retrieve information from the server about [path to backup file].

I have now tried it with two different backup files and receive the same error. Any assistance is greatly appreciated!

Thanks.
Back to top
View user's profile Send private message
daveh



Joined: 24 Apr 2008
Posts: 2

PostPosted: Thu Apr 24, 2008 11:18 pm    Post subject: Reply with quote

Err, I feel stupid (hey, it is 8:00 am on public holiday here and I'm at work!). It was actually just an issue with file permissions! I had copied the file itself to the server with a user who had domain admin permissions. I was then using SQL Backup from a remote PC on a different domain. As soon as I changed the permissions to make it accessible to any user on the machine, all was well!
Back to top
View user's profile Send private message
Bgfreeman



Joined: 23 Apr 2010
Posts: 15

PostPosted: Sat Apr 24, 2010 11:32 am    Post subject: Same problem, no solution Reply with quote

I have a 28Gb backup file from a production server, copied to the mirror server. The database itself is 125Gb.

I have copied this same file to a Dev server and restored without problems.

On the mirror server I get the red 'X' and the tooltip states 'Could not retrieve information from the server about <filename>'

I set the permissions on the file, folder and parents to 'Everyone, Full Control' and nothing has changed. I've restarted SQLB as well.

It takes several hours to copy this file, so I don't want to have to do it again.

We're on a 14-day trial of SQLB, but if I can't use it then I don't see the point in purchasing it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group