Red Gate forums :: View topic - Dependency not shown when used from XAML only
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SmartAssembly 6
SmartAssembly 6 forum

Dependency not shown when used from XAML only

Search in SmartAssembly 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
dybalabj



Joined: 06 Oct 2008
Posts: 16

PostPosted: Mon Mar 03, 2014 6:39 pm    Post subject: Dependency not shown when used from XAML only Reply with quote

Hello,

I have a dependency that is not showing up in the list in my SmartAssembly project (Kent.Boogaart.Converters.dll, can be downloaded from http://wpfconverters.codeplex.com/releases/view/104331).

If I use this dependency in code-behind (see this thread), then the dependency shows up. But if I only use the dependency in my XAML, then it's not showing in the list.

I am running SmartAssembly 6.8.0.121
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 235

PostPosted: Tue Mar 04, 2014 11:25 pm    Post subject: Reply with quote

Hi there,

Because SmartAssembly will only pick up on dependencies that are referenced in the main assembly's metadata, it will only detect dependencies that are directly referenced and called on by the code behind. (I did a quick check and it doesn't look like using an assembly from the xaml will add any reference to it in the metadata :/ )
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group