Red Gate forums :: View topic - Error generating HTML report in Command Line
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Compare 10
SQL Compare 10 forum

Error generating HTML report in Command Line

Search in SQL Compare 10 forum
Post new topic   Reply to topic
Jump to:  
Author Message
espo4life



Joined: 31 Oct 2012
Posts: 2

PostPosted: Wed Oct 31, 2012 6:51 pm    Post subject: Error generating HTML report in Command Line Reply with quote

I am using SQL Compare 10 with the following command line

Code:
SQLCompare /Scripts1:"C:\Database" /db2:"Database" /Server2:"Server" /ScriptFile:"C:\Database\output.sql" /Force /Exclude:User /Report:"c:\Database\DatabaseReport.html" /ReportType:Simple


and it gives me the following with the /Report tag present.

Code:

Unexpected error: Object reference not set to an instance of an object.
Object reference not set to an instance of an object.
System.NullReferenceException
   at #i9G.#wamb.#0CIc()
   at #i9G.#wamb.#jcmb()
   at #i9G.#wamb.#9OVb()
   at RedGate.SQLToolsCommandLine.CommandProcessor.#ZjD()
   at RedGate.SQLToolsCommandLine.CommandProcessor.#kcmb()
   at #i9G.#wamb.#kcmb()
   at RedGate.SQLToolsCommandLine.CommandProcessor.#OUb()
   at #i9G.#OsPb.#6sc(String[] #ead)

Any ideas on the problem and how to fix it?

Thanks,
Michael
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6678

PostPosted: Thu Nov 01, 2012 10:25 am    Post subject: Reply with quote

Can you try appending /Include:Identical to the command?
Back to top
View user's profile Send private message
sddesh



Joined: 13 Dec 2012
Posts: 2

PostPosted: Thu Dec 13, 2012 11:54 pm    Post subject: Reply with quote

Did you find an answer to this issue? Having the same problem. Thanks.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6678

PostPosted: Fri Dec 14, 2012 10:39 am    Post subject: Reply with quote

Nope. No solution and can't reproduce it in-house.
Back to top
View user's profile Send private message
sddesh



Joined: 13 Dec 2012
Posts: 2

PostPosted: Tue Dec 18, 2012 11:01 pm    Post subject: Reply with quote

SqlCompare /S1:server1 /db1:database1 /S2:server2 /db2:database2 /Exclude:Schema /Exclude:User /Exclude:Role /Options:Default,IgnoreComments,IgnorePermissions,IgnoreFillFactor,IgnoreWhiteSpace,IgnoreQuotedIdentifiersAndAnsiNullSettings,IgnoreExtendedProperties,IgnoreWithNocheck,IgnoreConstraintNames /report:"C:\test.xml" /reporttype:XML /force /loglevel:verbose

gives the above mentioned "object reference not set to instance of object error". Could you please look at it? Am I doing anything wrong here? This is working when I send the output to a text file using /out: variable (without report generation). But erroring while trying to do a report.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6678

PostPosted: Wed Dec 19, 2012 11:40 am    Post subject: Reply with quote

Please contact support at red-gate.com by email. We'll probably need to debug the program with you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group