Red Gate forums :: View topic - SmartAssembly v.6.7.0.239 error without obfuscating anything
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SmartAssembly 6
SmartAssembly 6 forum

SmartAssembly v.6.7.0.239 error without obfuscating anything

Search in SmartAssembly 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
maximusdm



Joined: 04 Oct 2012
Posts: 3

PostPosted: Thu Oct 04, 2012 11:17 pm    Post subject: SmartAssembly v.6.7.0.239 error without obfuscating anything Reply with quote

hi all
just got the latest and trial version and tried to obfuscating without activating or using any features such as control flow, etc...
It looks like is trying to validate the license. I am getting this error when I ran my program:

Stack Trace:
[ArgumentNullException: String reference not set to an instance of a String.
Parameter name: s]
System.DateTimeParse.Parse(String s, DateTimeFormatInfo dtfi, DateTimeStyles styles) +4579778
System.DateTime.Parse(String s) +27
SmartAssembly.License.License.() +534
SmartAssembly.License.License.ValidateDLL() +39
.cctor() +31

[TypeInitializationException: The type initializer for '<Module>' threw an exception.]
System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandle& ctor, Boolean& bNeedSecurityCheck) +0
System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean fillCache) +146
System.RuntimeType.CreateInstanceImpl(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean fillCache) +298
System.Activator.CreateInstance(Type type, Boolean nonPublic) +79
System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes) +10366539
System.Web.HttpApplicationFactory.GetSpecialApplicationInstance(IntPtr appContext, HttpContext context) +258
System.Web.Hosting.PipelineRuntime.InitializeApplication(IntPtr appContext) +382

[HttpException (0x80004005): The type initializer for '<Module>' threw an exception.]
System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +11318726
System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +88
System.Web.HttpRuntime.ProcessRequestNotificationPrivate(IIS7WorkerRequest wr, HttpContext context) +4347796

Any ideas?

Thank you
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 232

PostPosted: Sat Oct 06, 2012 12:30 am    Post subject: Reply with quote

Hello!

Thanks for your post. Can I check--are you running the program on a different machine from where it was built (by SmartAssembly)? Assemblies built by a trial version of SmartAssembly can't be distributed, I'm afraid, though it should work fine on the original machine! Very Happy
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
maximusdm



Joined: 04 Oct 2012
Posts: 3

PostPosted: Sat Oct 06, 2012 6:09 pm    Post subject: Re: Reply with quote

jessica.ramos wrote:
Hello!

Thanks for your post. Can I check--are you running the program on a different machine from where it was built (by SmartAssembly)? Assemblies built by a trial version of SmartAssembly can't be distributed, I'm afraid, though it should work fine on the original machine! Very Happy


Jessica,
That does not make sense. I have a C# console app which I compiled with SmartAssembly and has been running in our lab for a week. It does show a warning that it will expire in 2 weeks or so.
I compiled in my laptop and am running in different servers.
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 232

PostPosted: Wed Oct 10, 2012 12:07 am    Post subject: Reply with quote

Sorry about that! You're right, my distributed test app does seem to work (though it should still expire after 2 weeks). I'm trying to sort out now when it will give an expiration warning vs. when it simply won't run.

For now, does that same C# app that's working on other machines run successfully on the machine giving this ArgumentNullException error?
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
maximusdm



Joined: 04 Oct 2012
Posts: 3

PostPosted: Thu Oct 11, 2012 5:24 pm    Post subject: Re: Reply with quote

jessica.ramos wrote:
Sorry about that! You're right, my distributed test app does seem to work (though it should still expire after 2 weeks). I'm trying to sort out now when it will give an expiration warning vs. when it simply won't run.

For now, does that same C# app that's working on other machines run successfully on the machine giving this ArgumentNullException error?


It does! flawlessly! but it's a console app. The problematic app is a asp.net app compiled into one final DLL with a dependency in another core DLL. The core DLL is not being obfuscated.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group