Red Gate forums :: View topic - Incompatibility with v4.0 app pools on server?
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Monitor 3
SQL Monitor 3 forum

Incompatibility with v4.0 app pools on server?

Search in SQL Monitor 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
tdietrich



Joined: 04 May 2012
Posts: 8

PostPosted: Mon Jun 11, 2012 3:14 pm    Post subject: Incompatibility with v4.0 app pools on server? Reply with quote

Running SQL Monitor 3.1 on a v4.0 app pool, I get this error on browsing to the site:

Quote:
There is a duplicate 'system.web.extensions/scripting/scriptResourceHandler' section defined


If I change the app pool to be v2.0, the site works perfectly well. I was not able to find any documentation stating that SQL Monitor should have it's app pool set to v2.0, so it may be worth either fixing that bug or adding that information to the installer where it tells you to set up the IIS site.

Thanks.
Back to top
View user's profile Send private message
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Mon Jun 11, 2012 4:42 pm    Post subject: Reply with quote

This is a known issue but I've raised an enhancement to get our IIS documentation updated with this fact (reference: SRP-7057).

Unfortunately a fix is a far bigger undertaking. .NET 4.0 is more widespread now so hopefully we'll be able to fully support it in a future release.

Regards
Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group