Red Gate forums :: View topic - Clarify Web Application protection please.
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SmartAssembly 6
SmartAssembly 6 forum

Clarify Web Application protection please.

Search in SmartAssembly 6 forum
Post new topic   Reply to topic
Jump to:  
Go to page Previous  1, 2
Author Message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6577

PostPosted: Wed May 16, 2012 1:27 pm    Post subject: Reply with quote

We may need a copy of the compiled website to reproduce the problem in-house. I cannot reproduce the problem, so it must be something specific to your application.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6577

PostPosted: Fri May 18, 2012 2:14 pm    Post subject: Reply with quote

What version of SmartAssembly are you using? It seems there was a bug in 6.5 that was fixed in 6.6. The SecurityCriticalAttribute needed to be applied to SmartAssembly's serialization code.

Following this logic, you may also want to try setting the web application to run with full trust in the web.config.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6577

PostPosted: Wed May 23, 2012 12:22 pm    Post subject: Reply with quote

Does setting web_fulltrust make the protected web application work?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Go to page Previous  1, 2
Page 2 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group