Red Gate forums :: View topic - No results to display message
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 7
ANTS Performance Profiler 7 forum

No results to display message

Search in ANTS Performance Profiler 7 forum
Post new topic   Reply to topic
Jump to:  
Author Message
dontas



Joined: 25 Feb 2012
Posts: 1

PostPosted: Sat Feb 25, 2012 12:41 pm    Post subject: No results to display message Reply with quote

When I try to profile a web application I get the message "No results to display". I checked Event Viewer and I it has an event ".NET Runtime version 4.0.30319.261 - Loading profiler failed during CoCreateInstance. Profiler CLSID: '{5017EBB4-4220-4965-A61F-035BEF6E98A9}'. HRESULT: 0x80040111. Process ID (decimal): 5348. Message ID: [0x2504]."
How can this problem be fixed.

Thank you.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6666

PostPosted: Mon Feb 27, 2012 12:34 pm    Post subject: Reply with quote

Hello,

There are multiple causes for this, so it's hard to say. First, make sure that you haven't installed the new "always-on" profiling module into IIS. This will prevent you from doing regular profiling of IIS, so you will need to remove the profiler module from the IIS configuration before you can use ANTS the regular way.

This can also happen when the profiler Core DLL is not registered. In some extreme cases, it indicates a failure in ProfilerCore.dll's initialize method.
Back to top
View user's profile Send private message
mjokumsen



Joined: 28 Feb 2012
Posts: 1

PostPosted: Tue Feb 28, 2012 4:54 pm    Post subject: Reply with quote

I have the same issue on a fresh install. Is there a way we can register the profiler again? If so - how?
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6666

PostPosted: Tue Feb 28, 2012 6:19 pm    Post subject: Reply with quote

Registering the dll is just a matter of opening a console and running regsvr32 c:\program files\red gate\ants performance profiler 7\ProfilerCore.dll.

If it's a "fresh install" and you have run the Continuous profiling installer, then the continuous profiling module needs to be removed from IIS before you can profile IIS. The quickest way to test this is to profile a regular desktop application. If that works and IIS doesn't, you have probably installed the continuous profiling module.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group