Red Gate forums :: View topic - Timing mystery
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 7
ANTS Performance Profiler 7 forum

Timing mystery

Search in ANTS Performance Profiler 7 forum
Post new topic   Reply to topic
Jump to:  
Author Message
OlafMeding



Joined: 25 Jan 2011
Posts: 3

PostPosted: Tue Feb 21, 2012 12:00 am    Post subject: Timing mystery Reply with quote

Why would the performance profiler show 839 ms for line 1 and 1000 ms for line 6? The profiler is set to wall clock time.

I am using ANTS Performance Profiler 7.0 downloaded last week on Windows XP, Visual Studio 2010, and C# code.

1 int n = TestSleep(1000);
2 Debug.WriteLine(string.Format("n: {0}", n));
3}

4private int TestSleep(int ms)
5{
6 Thread.Sleep(ms);
7 return 123;
8}

Thank you for your help.
Olaf
[/url]
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 586

PostPosted: Fri Feb 24, 2012 2:23 pm    Post subject: Reply with quote

That's rather odd - I just tried it and got, respectively:

1000.240 ms

&

1000.027

Feel free to send your results to us at support and we'll take a look.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group