Red Gate forums :: View topic - DEP related backup failure on 3 similar databases
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Backup 6
SQL Backup 6 forum

DEP related backup failure on 3 similar databases

Search in SQL Backup 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
epetro



Joined: 31 May 2011
Posts: 55
Location: Zotec Partners

PostPosted: Thu Feb 02, 2012 3:12 pm    Post subject: DEP related backup failure on 3 similar databases Reply with quote

Last night we experienced 3 similar scenarios on seperate servers regarding DEP. While 'frowned' upon, we perform nightly backups directly across the network. We have been successfully running v6.5.1.9 for 2 weeks on Windows Server 2003 R2 SP2 x64.

"To help protect your computer, Windows has closed this program."
Name: SQL Backup Service Application
Publisher: Red Gate Software Ltd.


A quick search of the forums yielded little help. DEP issues existed once, but "were resolved" in 2007.

I'm not sure which log(s) are most useful, but I can post them if requested.(since the service stopped, the GUI doesn't register this backup)
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1144
Location: My desk.

PostPosted: Fri Feb 03, 2012 4:13 pm    Post subject: Reply with quote

Thanks for your post, and sorry you're having a little trouble.

I've not heard of any DEP related issues recently- perhaps a windows update has triggered it?
You should be able to exclude the SQL Backup engine from DEP by right-clicking "My Computer", selecting "Properties", going to the "Advanced" tab, then "Settings" (under Performance). The DEP tab in the screen that appears allows you to exclude the SQL Backup service.

I'm not sure if it will have produced any useful log information if Windows killed the process, although you may find more reasons as to why in the Windows event logs.
Back to top
View user's profile Send private message
epetro



Joined: 31 May 2011
Posts: 55
Location: Zotec Partners

PostPosted: Fri Feb 03, 2012 4:18 pm    Post subject: Reply with quote

We have extra variables in our environment for month end. I will likely have to chalk it up to a fluke. The event log was not very helpful and I can't find a reference to the backup log file. If it is an error in code(yours or ours), I am sure it will turn up again.

I'd prefer to have this record at least in case others are searching for the event.
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1144
Location: My desk.

PostPosted: Fri Feb 03, 2012 4:19 pm    Post subject: Reply with quote

No problem - if it's persistent let us know, but it's not a problem I've seen reported elsewhere recently.
Hope it behaves going forwards!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group