Red Gate forums :: View topic - Compare just a single table via the command line
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Data Compare Previous Versions
SQL Data Compare Previous Versions forum

Compare just a single table via the command line

Search in SQL Data Compare Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
troyhunt



Joined: 28 Nov 2010
Posts: 15
Location: Australia

PostPosted: Wed Aug 03, 2011 3:06 am    Post subject: Compare just a single table via the command line Reply with quote

I'm struggling with something which should be very basic but I'm just not sure what I'm missing. I have two DBs from which I want to compare just a single table via the command line. I'm presently running this command:

SQLDataCompare.exe" /s1:(local) /db1:DB1 /s2:(local) /db2:DB2 /Include:table:\[MyTable\] /v

However, every common table in the DBs are compared (I think I'm probably misinterpreting the "include" switch as a whitelist). What am I missing here?

BTW, this is with the current version, 9.0.0.117
Back to top
View user's profile Send private message
Chris Auckland



Joined: 24 Oct 2006
Posts: 755
Location: Red Gate Software Ltd.

PostPosted: Wed Aug 03, 2011 9:29 am    Post subject: Reply with quote

Hi Troy,

I'm afraid your syntax is correct and this is a bug with SDC 9.0 (bug ref: SDC-1243). The /include switch doesn't seem to work.

There are a few workarounds you could use for the time being:

1) Create a project in the GUI, and then reference the project file using /project switch
2) The /exclude switch still works, so you could exclude the tables you don't want.
3) Downgrade to SQL Data Compare 8

I hope this helps for now, and sorry for the inconvenience.

Regards,

Chris
_________________
Chris
Back to top
View user's profile Send private message Send e-mail
danere



Joined: 12 Aug 2010
Posts: 3
Location: Sydney, Australia

PostPosted: Wed Aug 03, 2011 10:13 am    Post subject: Reply with quote

You could also try writing a negative regular expression for the /Exclude parameter as a workaround, e.g. exclude all except this table name string. I just had a bash at this but kept getting tripped up by reserved characters on the command line, so that might be fiddly to get right.

Dan
Back to top
View user's profile Send private message
troyhunt



Joined: 28 Nov 2010
Posts: 15
Location: Australia

PostPosted: Fri Aug 05, 2011 6:32 am    Post subject: Re: Reply with quote

Chris Auckland wrote:


1) Create a project in the GUI, and then reference the project file using /project switch
2) The /exclude switch still works, so you could exclude the tables you don't want.


Unfortunately number 1 is throwing the same exception against this syntax: SQLDataCompare.exe /pr:MyCompareFile.sdc

And number 2 would be rather unpleasant given the number of tables in the DB.

Any word on the timeline for a fix?
Back to top
View user's profile Send private message
justin.caldicott



Joined: 20 Apr 2011
Posts: 55

PostPosted: Fri Aug 05, 2011 9:57 am    Post subject: Reply with quote

Hello Troy,

Just to say that we've fixed the problem. We're just waiting on test resource before shipping you a private copy.

Justin
Back to top
View user's profile Send private message
Jaykul



Joined: 19 Aug 2011
Posts: 1

PostPosted: Fri Aug 19, 2011 7:18 pm    Post subject: Reply with quote

Can I just say: holy cow what a HUGE bug ... when can we get a fix? This totally blocks the new toolbelt release for us.
Back to top
View user's profile Send private message AIM Address
peter.peart
Site Admin


Joined: 02 Sep 2008
Posts: 362
Location: Top floor, RG towers with the cool kids

PostPosted: Tue Aug 23, 2011 4:26 pm    Post subject: Reply with quote

There's now a patch release to fix this available from the below link:

ftp://support.red-gate.com/patches/SQL_Data_Compare/Azure/SQL%20Data%20Compare_9.1.0.365_x86_r173469.exe

HTH!

Pete
_________________
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
Back to top
View user's profile Send private message Send e-mail
troyhunt



Joined: 28 Nov 2010
Posts: 15
Location: Australia

PostPosted: Sun Aug 28, 2011 8:17 am    Post subject: Reply with quote

Beautiful, thanks Peter, the patched version is working just fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group