Red Gate forums :: View topic - Error after obfuscation
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SmartAssembly 5
SmartAssembly 5 forum

Error after obfuscation

Search in SmartAssembly 5 forum
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
Jump to:  
Author Message
lbargers



Joined: 06 Dec 2010
Posts: 3

PostPosted: Tue Jan 04, 2011 9:45 pm    Post subject: Error after obfuscation Reply with quote

Hi,

Im getting the following error after running my vb.net project through the SA obfuscator. Error - Identifer '#cBb' is not CLS-compliant. Parameter name: ident

Any ideas where I should be begin to get past this?

Thanks,

LB
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6670

PostPosted: Thu Jan 06, 2011 11:22 am    Post subject: Reply with quote

The identifier #cBb is CLS-compliant, so the problem is not evident using the supplied error information.

Are you obfuscating a .NET 1.x assembly? The rules may have been different at that time. Particularly "Jagged arrays" could be mistakenly reported as non-complaint by the runtime.
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 591

PostPosted: Thu Jan 13, 2011 3:44 pm    Post subject: Reply with quote

Searching through known issues - this has occurred in the past because of an obfuscated serialized object.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies. All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group