Red Gate forums :: View topic - Exception on Win7 when try to Profile with SQL Record
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 6
ANTS Performance Profiler 6 forum

Exception on Win7 when try to Profile with SQL Record

Search in ANTS Performance Profiler 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
oliver



Joined: 28 Oct 2010
Posts: 3

PostPosted: Thu Oct 28, 2010 12:25 pm    Post subject: Exception on Win7 when try to Profile with SQL Record Reply with quote

Hi,

if i try to Profile a .Net .exe Application with the following Settings:
- Method Line
- Record SQL

after a few Seconds i will get an Profiler-Exception Dialog.

If i try to profile without SQL recording, there is no problem.
This is what i found in the antsprofiler-xxx.log:

28 Oct 2010 13:07:50.997 [1] INFO RedGate.Profiler.Logging.LogService - Starting new ANTS Performance Profiler 6 session
28 Oct 2010 13:07:51.012 [1] INFO RedGate.Profiler.Logging.LogService - Assembly version: 6.0.0.1312
28 Oct 2010 13:07:57.315 [1] WARN RedGate.Profiler.OS.Local.LocalWindowsVersionInspector - Detected Windows version: Windows Vista Enterprise (6.1 64-bit)
28 Oct 2010 13:07:57.315 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is supported on installed OS version
28 Oct 2010 13:07:57.330 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Result of check to see if inetinfo.exe running: False
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Result of check to see if W3SVC running: False
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checks suggest that IIS does not appear to be running.
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checking for existence of inetinfo.exe at 'C:\Windows\system32\inetsrv\inetinfo.exe'
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Unable to find inetinfo.exe
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Result of check to see if W3SVC running: False
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checks confirm that IIS is not enabled.
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Successfully detected IIS installation: IIS 7 (Auto-detected) (Not verified) (Disabled)
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checks confirm that IIS is not installed.
28 Oct 2010 13:15:21.825 [1] ERROR RedGate.Profiler.Engine.Startup.Trigger.TriggerServer - Trigger process failed to start
28 Oct 2010 13:15:22.012 [1] ERROR RedGate.Profiler.UI.Ignition - SmartExceptionsCore.UnhandledException @ 7455, offset:27
28 Oct 2010 13:15:22.012 [1] ERROR RedGate.Profiler.UI.Ignition - SmartAssembly.SmartExceptionsCore.UnhandledException
28 Oct 2010 13:15:22.028 [1] ERROR RedGate.Profiler.UI.Ignition -


So i try to use Ants Performance Profiler on a fresh installed Windows7 OS.

Any idea?

Greetings
Oliver
Back to top
View user's profile Send private message
nick.maidment



Joined: 29 Jan 2010
Posts: 74

PostPosted: Thu Oct 28, 2010 1:31 pm    Post subject: Reply with quote

Hi Oliver,

I just sent you an email. Please let me know if you get it.

Anyone else running into a problem with the "Trigger Process" should contact support @ red-gate .com directly.
Back to top
View user's profile Send private message
oliver



Joined: 28 Oct 2010
Posts: 3

PostPosted: Thu Oct 28, 2010 1:34 pm    Post subject: Reply with quote

Hi,

thank you for your reply.
I will try the patch.
Back to top
View user's profile Send private message
oliver



Joined: 28 Oct 2010
Posts: 3

PostPosted: Fri Oct 29, 2010 11:52 am    Post subject: Reply with quote

I tried your patch, but still the same.

I found the following entry on the old Log - File:
28 Oct 2010 13:07:57.471 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Checks confirm that IIS is not installed.

So i checked the OS-Installation and the InternetInformationService was not installed. I installed the IIS, now there is no exception.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group