Red Gate forums :: View topic - Pre-requisite installation error
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 6
ANTS Performance Profiler 6 forum

Pre-requisite installation error

Search in ANTS Performance Profiler 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
seanwinstead



Joined: 10 May 2006
Posts: 6
Location: Colorado, USA

PostPosted: Wed Oct 20, 2010 4:32 pm    Post subject: Pre-requisite installation error Reply with quote

Hi,

When I try to install ANTS Profiler, the installation fails when trying to install the prerequisite VC++ 2008 SP1 redistributable. The error message states "error 3010 when running program".

Does anyone know the possible causes of this error or how I might diagnose the problem?
_________________
Sean Winstead
Back to top
View user's profile Send private message Send e-mail
nick.maidment



Joined: 29 Jan 2010
Posts: 74

PostPosted: Wed Oct 20, 2010 5:20 pm    Post subject: Reply with quote

Typically an msi error of 3010 would indicate a reboot is required to complete the application: http://msdn.microsoft.com/en-us/library/aa368542%28VS.85%29.aspx

I have however, known this *not* to work. If you're using the dotnetdeveloper bundle installer you can unpack the individual msi files by running the bundle exe.

Don't go any further forward than the initial double click (but don't quit the installation)

If you look in explorer and the root of your drive, you should see that the exe extracting itself into a number of "randomly" named folders. When I've been doing it here, one folder was named "{A2600538-4173-4071-A903-270763B0A534}" for example.

Inside these folders you should be able to navigate and find the .msi files for the various products in the bundle.
Back to top
View user's profile Send private message
seanwinstead



Joined: 10 May 2006
Posts: 6
Location: Colorado, USA

PostPosted: Wed Oct 20, 2010 7:54 pm    Post subject: Reply with quote

Thank you for the guidance. I did complete the installation but had to take a different path from what you described.

At first, I did as you instructed and ran the VC redistributable exe that was decompressed from the setup package. But it gave me a screen asking if i wanted to repair or uninstall the VC++ 2008 redist.

I chose to repair and I rebooted. This did not affect the overall installation process. It still failed with the same error message. I did this twice.

So I took another path. I searched for and downloaded the VC++ 2008 SP1 redistributable and installed it. After I did that, the Red Gate installation worked as expected.
_________________
Sean Winstead
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group