Red Gate forums :: View topic - Slow Virtual Restore
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Virtual Restore 2
SQL Virtual Restore 2 forum

Slow Virtual Restore

Search in SQL Virtual Restore 2 forum
Post new topic   Reply to topic
Jump to:  
Author Message
mat.raftree



Joined: 29 Dec 2009
Posts: 3

PostPosted: Thu Sep 30, 2010 6:46 pm    Post subject: Slow Virtual Restore Reply with quote

I have been testing Virtual Restore times and in my environment, performing a full restore from a SQLBackup 6 .sqb file take about 60 minutes. I have made several attempts to do a virtual restore on the same SQB file and they run for about 180+ minutes each time.

I did the install of the hyperbac components with a recent download and it appears to be version 5.0.33.0 on them and I am running Windows 2003 Server 64bit and SQL Server 2008 Enterprise edition.

The SQB file is about 100GB and was perfomed with SQLBackup using 2 threads. I restores successfully from SQLBackup up to a 500GB database.

Is there anything obvious I am missing? I basically ran the Virtual Restore wizard and then copied the script and ran that from a query window (it is restoring all the files to .vmdf/.vndf files).

Is this expected behavior? I would have assumed that VirtualRestore would make the DB available faster than running a full resotre with SQLBackup.

Thanks for any help or thoughts
Back to top
View user's profile Send private message
eddie davis



Joined: 14 Jun 2006
Posts: 922
Location: Red Gate Software

PostPosted: Thu Oct 07, 2010 1:14 pm    Post subject: Reply with quote

Hi

I believe that my colleague, Jeff Aven, has already contacted you regarding this problem outside of this forum.

Do you require any further assistance?

Many Thanks
Eddie
_________________
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
stevenwatson



Joined: 19 May 2011
Posts: 3
Location: Australia

PostPosted: Fri May 20, 2011 1:09 am    Post subject: virtual restore does not complete Reply with quote

Could the details of this issue be posted, as I believe I'm having a similar issue.

On a large sql backup DB the virtual restores just continue indefinitely.

The restore is in two parts.
First the full backup is restored and left ready for the differential restore.
This seems to happen although a bit slower than a normal restore.
However the differential restore does not complete even if left running for several days.
Back to top
View user's profile Send private message
epetro



Joined: 31 May 2011
Posts: 55
Location: Zotec Partners

PostPosted: Fri Jun 03, 2011 7:41 pm    Post subject: Don't forget the stats Reply with quote

I too am attempting a large restore for evaluating purposes. My scenario is across the network as I want to eventually schedule DBCC processes on all our production servers once a week from a central location.

I found adding the "STATS=10" to the restore script helped me track the progress. I think you can use lower (%) to track tighter.

The process seems disk heavy at the source, so I may just pull the .sqb file locally to faster disks first.
Back to top
View user's profile Send private message
rplescia



Joined: 01 Nov 2011
Posts: 3

PostPosted: Tue Nov 01, 2011 4:22 pm    Post subject: Reply with quote

What is the average restore/mount time for a uncompressed 1GB SQL backup file using SVS? I'm restoring a 68GB uncompressed .sqb file which has been running for over 4 hours now and is roughly 75% complete. The data files are also at 21GB and still growing... Is this normal?

Server spec
HP DL 585 G3, 4 CPUs, 16GB RAM, SQL 2008 R2 64-bit

HyperBack 5.4.1.4
SQL Virtual Restore 5.2.1.7
Back to top
View user's profile Send private message
jhboricua



Joined: 15 Mar 2011
Posts: 28

PostPosted: Wed Jan 23, 2013 7:41 pm    Post subject: Reply with quote

So what is the scoop on this?

I'm just having the same issue with slow restores on a 40GB SQL Backup 6 SQB file (1 stream, compression level=1). At the current rate of restore it will take >200 minutes to complete!!!

I'm running the latest version of the SQL virtual Restore (downloaded it 2 weeks ago from the Red-Gate website).

I've found other old threads here alluding to slow virtual restore issues with no indication that the slowness issue has ever been resolved.

Can someone from Red Gate update shed some light on this?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group