Red Gate forums :: View topic - "Print Search Results" option does not work
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Aardvark
Aardvark forum

"Print Search Results" option does not work

Search in Aardvark forum
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
Jump to:  
Author Message
Jason



Joined: 20 Apr 2006
Posts: 7

PostPosted: Thu Apr 20, 2006 9:59 am    Post subject: "Print Search Results" option does not work Reply with quote

Hi,

We are using the latest Aardvark, and we have a problem when a user presses the "Print Search Results" option.

The SQL server will "max out" at 100% CPU for about 3 mins, and then no results will be displayed - we only get a drop down box, and a link to "open in new window"

When clicking on the "view raw XML" we get this message:

===============================================
The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

Whitespace is not allowed at this location. Error processing resource 'http://aardvark.advaoptical.com/aardvark/reports/{B8...

<CUSTOMFIELD CODE="Hardware & Revision"></CUSTOMFIELD>
-----------------------------^
===============================================

(the arrow points to just after the & sign.)
Back to top
View user's profile Send private message
Jason



Joined: 20 Apr 2006
Posts: 7

PostPosted: Thu Apr 27, 2006 8:31 am    Post subject: Any follow up on this? Reply with quote

Hi,

I was wondering if there is any follow up to this issue? It is currently causing problems for our engineering department, as they cannot get bug reports for their meetings. If there is any information you require, please let me know and I will get back to you immediately.

Thanks,

Jason
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6677

PostPosted: Thu Apr 27, 2006 5:52 pm    Post subject: Reply with quote

Hi,

Sorry I totally missed this issue altogether. I'll try to help out here...

Can you please check that all of the XSL files exist in the aardvark\web\xsl folder:

02/12/2002 11:30 4,841 Concise report with history.xsl
03/12/2002 12:03 4,393 concise.xsl
17/08/2002 10:18 1,708 csv.xsl
29/10/2002 11:33 608 kbcsv.xsl
25/10/2002 16:03 1,910 kbreport.xsl
25/10/2002 16:47 873 kbtab.xsl
02/12/2002 11:31 4,931 report with history.xsl
29/08/2002 12:26 4,481 report.xsl
17/08/2002 10:18 2,590 tab.xsl
Back to top
View user's profile Send private message
Jason



Joined: 20 Apr 2006
Posts: 7

PostPosted: Fri Apr 28, 2006 8:36 am    Post subject: Reply with quote

Hi Brian,

Yes, we have all those files, and the file sizes and dates match too.

Thanks,

Jason
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6677

PostPosted: Fri Apr 28, 2006 3:58 pm    Post subject: Reply with quote

Someone's been kind enough to let me know that the ampersand (&) is not allowed in XML documents; it is normally encoded as &amp.

I think that if you change the name of the custom field and remove the & character and replace it with 'and' it should get the whole thing working again.
Back to top
View user's profile Send private message
Jason



Joined: 20 Apr 2006
Posts: 7

PostPosted: Mon May 01, 2006 9:55 pm    Post subject: Fixed Reply with quote

Hi Brian,

Yes, this has fixed the issue - the report now works fine.

Thanks,

Jason
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies. All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group