Red Gate forums :: View topic - reindex not working on renamed stored procedure
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Search 2
SQL Search 2 forum

reindex not working on renamed stored procedure

Search in SQL Search 2 forum
Post new topic   Reply to topic
Jump to:  
Author Message
jihohanbnpp



Joined: 08 Aug 2014
Posts: 2

PostPosted: Fri Aug 08, 2014 8:28 pm    Post subject: reindex not working on renamed stored procedure Reply with quote

Using SQL 2005 Management Studio...

I renamed a stored procedure and clicked "reindex", it seemed to reindex. But when I search for the old name, the stored procedure is still returned in the result and has the old text (with the old name). Searching for the new name returns the same (with the old name after CREATE PROCEDURE). If I click "Select object in Object Explorer" it takes me to the renamed (now with new name) stored procedure in the object explorer.

I'm not sure if the lifetime of the index is for the duration of sql management studio but I haven't restarted mine so I can't confirm that.

Otherwise, this is a very simple and easy to use tool that offloads the work I have to do to search for terms in my procedures.

Thanks!

-----
Microsoft SQL Server Management Studio 9.00.4035.00
Microsoft Analysis Services Client Tools 2005.090.4035.00
Microsoft Data Access Components (MDAC) 6.1.7601.17514 (win7sp1_rtm.101119-1850)
Microsoft MSXML 3.0 4.0 5.0 6.0
Microsoft Internet Explorer 9.0.8112.16421
Microsoft .NET Framework 2.0.50727.5477
Operating System 6.1.7601
-----
Back to top
View user's profile Send private message
Anu Deshpande



Joined: 20 Apr 2009
Posts: 692
Location: Cambridge

PostPosted: Mon Aug 11, 2014 1:38 pm    Post subject: Reply with quote

Thanks for your post and sorry for the issue you are having.

Can you please follow below mentioned steps:

1. Close SSMS

2. Delete contents of this index folder: C:\Users\<username>\AppData\Local\Red Gate\SQLSearch 2\Indexes
3. Open SSMS

4. Try to replicate the issue.

Does this helps?
_________________
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group