Red Gate forums :: View topic - SQL Search missing in MSSMS 2008
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Search 1
SQL Search 1 forum

SQL Search missing in MSSMS 2008

Search in SQL Search 1 forum
Post new topic   Reply to topic
Jump to:  
Author Message
vyskol



Joined: 09 Mar 2012
Posts: 2

PostPosted: Wed Feb 05, 2014 5:36 pm    Post subject: SQL Search missing in MSSMS 2008 Reply with quote

I have a licensed installation of SQL Prompt 6.2.0.366 as well as SQL Search 1.1.9.71.

I have MSSMS 2008 and MSSMS 2012 installed on my computer. In MSSMS 2012, SQL Search appears both in the SQL Prompt menu and the Red Gate toolbar. In MSSMS 2008, it is nowhere to be found.
Back to top
View user's profile Send private message
David Pond
Site Admin


Joined: 06 Mar 2012
Posts: 24
Location: Cambridge, UK

PostPosted: Sat Feb 08, 2014 7:39 pm    Post subject: Reply with quote

If you send me a PM with your e-mail address I will put you on the beta list for the new SQL Search release. One of the things we have changed is the way it loads into SSMS*, so I think there's a good chance it will fix the issue you're having.

It now loads through the SSMS Ecosystem project: https://www.simple-talk.com/blogs/2013/11/22/introducing-the-red-gate-ssms-ecosystem/
Back to top
View user's profile Send private message Send e-mail
Powlin



Joined: 16 May 2007
Posts: 34

PostPosted: Fri Mar 28, 2014 7:17 pm    Post subject: Reply with quote

same problem here, I'm using SQL Search 1.1.10.484 and it doesn't load in SSMS 2008.
Back to top
View user's profile Send private message
Chris.Morter



Joined: 17 Jul 2013
Posts: 2

PostPosted: Mon Mar 31, 2014 3:58 pm    Post subject: Reply with quote

Hi Powlin, thanks for participating in the SQL Search beta program. I have tried to reproduce this problem on a fresh install of SSMS 2008 and found that SQL Search did load and function correctly. Do you have any more information that may help us to reproduce this issue?

In particular, did you have any other Red Gate extensions already installed in SSMS when you installed Search? We have recently been doing some development work to provide a common framework to load Red Gate extensions into SSMS and did find some initial problems in testing when the new extension loading mechanism was used alongside the existing one. We believe that these issues have now been resolved, but of course similar issues could remain.

Another possibility is that Search has loaded but the Red Gate toolbar is hidden. Visibility can be toggled by right-clicking some empty space in the SSMS toolbar, and clicking the Red Gate menu item
Back to top
View user's profile Send private message
Powlin



Joined: 16 May 2007
Posts: 34

PostPosted: Mon Mar 31, 2014 4:06 pm    Post subject: Reply with quote

Hi,

I was using the beta on my computer using Windows XP, it was working fine, i recently got a new computer using Windows 7 and It won't load on it. I tried the 2 last beta and the only one that work is version 1.1.9.57.

Integrated into SSMS, I'm using SQL Prompt, the Tab History was loading but not SQL Search (they are in the same toolbar)

I'm using SSMS 2008 R2 - 10.50.2500.0

Thanks
Back to top
View user's profile Send private message
Random Lengths



Joined: 29 Sep 2008
Posts: 26
Location: Eugene, OR

PostPosted: Thu Apr 24, 2014 8:08 pm    Post subject: Still deosn't work Reply with quote

I'm having the same issue with the Beta. I had it working with my SSMS 2008R2, and when I upgraded SSMS to 2012, SQL Search is now gone. I tried the SSMS Integration Pack Framework 1 Repair suggested, and it didn't work.

MUST HAVE MY SEARCH Very Happy
Back to top
View user's profile Send private message
Powlin



Joined: 16 May 2007
Posts: 34

PostPosted: Thu Apr 24, 2014 8:16 pm    Post subject: Reply with quote

I've installed the new beta SQL Search 2.0.1.8 and now the SQL Search tab is visible.

I got a new computer at work, and when installed the beta on a fresh installation of SSMS, the SQL Search tab wasn't here, but the Tab History was (I'm using SQL Prompt). Since it was not working I installed the official version that is working.

When a new beta version 2.0.1.8 was available I installed it to see if the problem is corrected and It look like corrected, but maybe it worked because I installed the official SQL Search (1.0.0) before installing the new version.

So maybe you could try installing 2.0.1.8, if it's not working try installing the 1.0.0 and upgrade to 2.0.1.8 after.
Back to top
View user's profile Send private message
Random Lengths



Joined: 29 Sep 2008
Posts: 26
Location: Eugene, OR

PostPosted: Thu Apr 24, 2014 9:23 pm    Post subject: Reply with quote

I was installing and reinstalling 2.0.1.8. But I tried uninstalling, then reinstalling 1.1.10.484, then installing 2.0.1.8.

My Tab History toolbar is back, but search is still missing.

After restarting SSMS this last time, I got 2 new error messages, perhaps they are related to the issue:

[img]c:\users\dlg\desktop\2014-04-24_13-12-25.jpg[/img]

[img]c:\users\dlg\desktop\2014-04-24_13-12-13.jpg[/img]

Though both mention RedGate.SQLSourceControl.SSMS2012.Addin and SQL Source Control seems to be working fine.
Back to top
View user's profile Send private message
domager



Joined: 28 May 2014
Posts: 5

PostPosted: Wed May 28, 2014 11:13 am    Post subject: Reply with quote

I'm having the same problem here but with the SQL Search 2 tool, I've recently rebuilt my machine, I'm running Win2008R2.

I first installed SSMS 2012 and then installed the SQL Search 2 tool, and all was working fine.

After finding SSMS 2012 a little sluggish I decided to install SSMS 2008 R2, but the Red Hat menu wasn't showing as an option, so I removed SQL Search 2 and reinstalled, but again it hasn't appeared in 2008, working fine in 2012 though.

Did this get resolved...?
Back to top
View user's profile Send private message
Random Lengths



Joined: 29 Sep 2008
Posts: 26
Location: Eugene, OR

PostPosted: Thu May 29, 2014 4:18 pm    Post subject: Re: Reply with quote

domager wrote:
I'm having the same problem here but with the SQL Search 2 tool, I've recently rebuilt my machine, I'm running Win2008R2.

I first installed SSMS 2012 and then installed the SQL Search 2 tool, and all was working fine.

After finding SSMS 2012 a little sluggish I decided to install SSMS 2008 R2, but the Red Hat menu wasn't showing as an option, so I removed SQL Search 2 and reinstalled, but again it hasn't appeared in 2008, working fine in 2012 though.

Did this get resolved...?


It did. They sent me the latest version at the time '2.0.1.28' and all was well.

Which version are you on?
Back to top
View user's profile Send private message
domager



Joined: 28 May 2014
Posts: 5

PostPosted: Mon Jun 02, 2014 9:39 am    Post subject: Re: Reply with quote

Random Lengths wrote:
It did. They sent me the latest version at the time '2.0.1.28' and all was well.

Which version are you on?


Looks like I'm on a slightly newer version than you, v2.0.1.30
Back to top
View user's profile Send private message
Random Lengths



Joined: 29 Sep 2008
Posts: 26
Location: Eugene, OR

PostPosted: Mon Jun 02, 2014 4:07 pm    Post subject: Re: Reply with quote

domager wrote:
Random Lengths wrote:
It did. They sent me the latest version at the time '2.0.1.28' and all was well.

Which version are you on?


Looks like I'm on a slightly newer version than you, v2.0.1.30


Sorry, I don't know what else to tell you, other than to contact support. They've always been quick to respond for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group