Red Gate forums :: View topic - Large differences in time measurements?
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 8
ANTS Performance Profiler 8 forum

Large differences in time measurements?

Search in ANTS Performance Profiler 8 forum
Post new topic   Reply to topic
Jump to:  
Author Message
freddyg



Joined: 24 Mar 2014
Posts: 3

PostPosted: Mon Mar 24, 2014 11:13 am    Post subject: Large differences in time measurements? Reply with quote

Hi,

I'm using the profiler for a while now.

I'm profiling a large linq query. When i switch to 'milliseconds display' (FCool i cannot explain the large differences between multiple runs. Recently I installed windows 8.1 and i'm not sure if this has something to do with my issue..

From the last four measures i get the following timings in the profiler: 787ms, 1406ms, 723ms as 1252ms.
My own added logger gave these values (for the complete function): 2435ms, 2498ms, 2456ms and 2519ms

My issues is that the profiler isn't giving equal measurements for the same code on multiple runs. I double checked the hit count, and it is always on 1.
Im following the same steps everytime when i start a profiling session.


How can the difference between the profiler and my logger be explained?
Why is there such a big difference between sessions? (723ms and 1406ms is almost a doubling in timing which i cannot see in my own measure results..)

Is this something i can fix on my side or is this an issue in the profiler software?


Sincerely,
Freddy
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 215

PostPosted: Wed Mar 26, 2014 12:11 am    Post subject: Reply with quote

Hi Freddy,

Sorry to hear you're seeing some weird results with the profiler!

I'm afraid I'm not immediately sure what''s causing this, but could I please check a few things..

-What profiling mode are you using? Does it make any difference to use a less detailed/more accurate mode such as method-level timings or sampling?

-Do you have the "adjust timings to compensate for overhead added by the profiler" turned on or off?

-Are you looking at CPU or Wall Clock time in the profiler?
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
freddyg



Joined: 24 Mar 2014
Posts: 3

PostPosted: Wed Mar 26, 2014 10:40 am    Post subject: Reply with quote

Hello Jesica,

I'm profiling IIS - ASP.NET on Line-level & method-level timings, all methods inc framework.

'adjust timings to compensate for overhead added by the profiler' is active (this is the default setting i believe)

The timing options is set to CPU time on milliseconds.



I can try a few different settings if you need more information but i'm worried about the inconsistent timings i get..


Thanks,
Freddy
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 215

PostPosted: Wed Mar 26, 2014 5:21 pm    Post subject: Reply with quote

Hi Freddy,

Would it be possible for you to share the application with us so we can try to reproduce the inconsistencies in-house?
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 215

PostPosted: Wed Mar 26, 2014 5:29 pm    Post subject: Reply with quote

Hi Freddy,

So sorry, I've just realized this is for an IIS website which probably won't be easily shared.

Could you kindly try different options (method level timings - only methods with source, disabling the overhead compensation) to see if that gives more consistent results?

It could also be helpful if you could share one or a few of your results files with us--please let me know if this is possible!
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
freddyg



Joined: 24 Mar 2014
Posts: 3

PostPosted: Mon Mar 31, 2014 2:08 pm    Post subject: Reply with quote

Hello Jessica,

Sorry, I couldn't respond earlier.

How can I share some files with you? I did 2 tests with method level and line level. I saved the output and also my own 'measurements'.


Sincerely,
Freddy
Back to top
View user's profile Send private message
jessica.ramos



Joined: 23 Apr 2012
Posts: 215

PostPosted: Mon Mar 31, 2014 11:19 pm    Post subject: Reply with quote

Hi Freddy,

No worries! We have a support ticket open for you (#15764)--I've just set up some FTP space for you to upload to and sent you the details through the ticket.

Please let me know if you don't receive that email!
_________________
Jessica Ramos
Technical Support
Red Gate Software Ltd.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group