Red Gate forums :: View topic - Can't Pinpoint Cause of CPU Usage (Silverlight)
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 8
ANTS Performance Profiler 8 forum

Can't Pinpoint Cause of CPU Usage (Silverlight)

Search in ANTS Performance Profiler 8 forum
Post new topic   Reply to topic
Jump to:  
Author Message
BSayatovic



Joined: 12 Nov 2013
Posts: 2

PostPosted: Tue Nov 12, 2013 4:56 pm    Post subject: Can't Pinpoint Cause of CPU Usage (Silverlight) Reply with quote

I'm using ANTS Performance Profiler 8.3 to try and track down the source of a CPU usage problem in my Silverlight application. After a couple of hours of usage, the CPU usage settles at 50% (on a dual-core computer; 25% on a quad-core, etc.) even when the application is effectively idle.

Here's a timeline:


During the first "idle" period, CPU usage is effectively 0%. During the last "idle" period, CPU usage is at 50%. I've compared the "hot spots" in call tree, and method grid and the hit counts, CPU ticks, etc. of the methods at each point are basically the same. It seems as though nothing *within* my application is what's using the CPU.

Can anyone confirm that it is possible to see CPU usage in the timeline of 50% (which I believe is measured by the Windows Performance Counter for the process) while ANTS Performance Profiler's own instrumentation doesn't actually catch the culprit?
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 585

PostPosted: Thu Nov 14, 2013 1:25 pm    Post subject: Reply with quote

I'm sorry but its very hard to know what the actual question is and, further, what the data you are using is- would you mind sending your results in to us at support@red-gate.com please? I'm sure all will be a lot clearer then. Smile
Back to top
View user's profile Send private message
BSayatovic



Joined: 12 Nov 2013
Posts: 2

PostPosted: Mon Nov 18, 2013 8:04 pm    Post subject: Re: Reply with quote

I somehow missed your forum reply until now. I've just e-mailed support directly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group