Red Gate forums :: View topic - Constraints are dropped but not re-added.
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Compare 10
SQL Compare 10 forum

Constraints are dropped but not re-added.

Search in SQL Compare 10 forum
Post new topic   Reply to topic
Jump to:  
Author Message
UKRoyster



Joined: 25 Jan 2013
Posts: 6

PostPosted: Thu Jul 18, 2013 2:02 pm    Post subject: Constraints are dropped but not re-added. Reply with quote

SQL Compare 10.3.8

I am struggling with the script generation. After comparing two databases, I can see that the generated script drops all constraints (Foreign keys), but no where in the script are they re-added again.

Hence, if I execute the script and perform another compare, it sees that the constraints were dropped.

I am sure its a simple solution, just can't figure it out.
_________________
Thanks,
Roy.

Looking for great hotel deals? Try http://lovehoteldeals.co.uk/
Back to top
View user's profile Send private message
andy.campbell.smith



Joined: 20 Oct 2011
Posts: 159
Location: Red Gate Software

PostPosted: Mon Jul 22, 2013 1:28 pm    Post subject: Reply with quote

This sounds like a bug we fixed in SQL Compare 10.4 - can I get you to upgrade and see if you're still hitting it? You can upgrade for free either by selecting Help->Check for Updates, or by downloading the installer here:

ftp://support.red-gate.com/patches/SQLCompare/03Jun2013/SQLCompare_10.4.8.87.exe

Let me know if that clears anything up!
_________________
Andy Campbell Smith

Red Gate Technical Support Engineer
Back to top
View user's profile Send private message
UKRoyster



Joined: 25 Jan 2013
Posts: 6

PostPosted: Mon Jul 22, 2013 2:01 pm    Post subject: Reply with quote

Bug is fixed. Thank you Andy.
_________________
Thanks,
Roy.

Looking for great hotel deals? Try http://lovehoteldeals.co.uk/
Back to top
View user's profile Send private message
john.hunter



Joined: 30 Jul 2009
Posts: 5

PostPosted: Tue Aug 13, 2013 11:31 am    Post subject: Reply with quote

I'm still having this problem with version 10.4.8.87 specifically dropping primary key and not adding it back.

I'm not sure why it is dropping the primary key in the first place.

EDIT: Ok I found that if I ignore indexes in my comparison the generated script drops Primary Keys but doesn't re-add them.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group