Red Gate forums :: View topic - Schema Compare breaks on upgrade from 3.0.0.523 to 3.0.0.686
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Schema Compare for Oracle
Schema Compare for Oracle forum

Schema Compare breaks on upgrade from 3.0.0.523 to 3.0.0.686

Search in Schema Compare for Oracle forum
Post new topic   Reply to topic
Jump to:  
Author Message
steve B



Joined: 23 Jul 2013
Posts: 4

PostPosted: Tue Jul 23, 2013 2:33 pm    Post subject: Schema Compare breaks on upgrade from 3.0.0.523 to 3.0.0.686 Reply with quote

Bug Report:

Upgraded Schema Compare for Oracle breaks when comparing a database schema VS a script schema created by the old version.

Problem lies in the scripts within the UserObjectPrivileges folder - new version prefixes each object name in these scripts with the owning schema. Scripts created by the old version do NOT include the "schema." prefix before each object name - The missing prefix appears to be what breaks Schema Compare.
Back to top
View user's profile Send private message
steve B



Joined: 23 Jul 2013
Posts: 4

PostPosted: Tue Jul 23, 2013 3:42 pm    Post subject: Reply with quote

Bug Report:

Using Redgate Schema Compare 3.0.0.686 command line to rebuild database schemas from RedGate generated script files.
We rebuild multiple schemas in one pass - so have an automated run that builds each schema in turn, but logging on each time as the SYSTEM user (this worked fine in 3.0.0.542)
The schema build scripts generated by Schema Compare for Oracle 3.0.0.686 OMIT THE SCHEMA PREFIX FROM PACKAGE NAMES (in create package and create package body commands) - So when rebuilding the schemas, it attempts to create stored code within the current schema (i.e. SYSTEM)!!
So after the schema rebuild, we're left with multiple broken schemas that need to be patched up manually.
Back to top
View user's profile Send private message
neil.anderson



Joined: 28 Sep 2010
Posts: 64

PostPosted: Tue Jul 23, 2013 6:26 pm    Post subject: Reply with quote

Hi steve,

Thanks for the bug reports. I'll look into them asap. In the meantime you can revert to 3.0.0.542 using this link:

http://download.red-gate.com/checkforupdates/SchemaCompareforOracle/SchemaCompareforOracle_3.0.0.542.exe

Sorry for the inconvenience.

Neil
Back to top
View user's profile Send private message
steve B



Joined: 23 Jul 2013
Posts: 4

PostPosted: Tue Jul 23, 2013 6:38 pm    Post subject: Reply with quote

Hi Neil,

We've currently got workarounds in place, as the capture of table and column comments in the new version outweighs the inconvenience of working around these 2 issues. But looking forward to seeing a version that captures comments AND is a little less buggy.

Thanks
Steve.
Back to top
View user's profile Send private message
neil.anderson



Joined: 28 Sep 2010
Posts: 64

PostPosted: Wed Jul 31, 2013 11:04 am    Post subject: Reply with quote

Hi Steve,

I cannot recreate the issue where SC is omitting the schema name from package names. How are you using the command line? Can you send me (oracle@red-gate.com) the project file if that is what you are using?

Does this occur all the time, even when you start afresh from the UI? Or is it just for certain objects?

Thanks,
Neil
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group