Red Gate forums :: View topic - SQL Prompt 6 issue with SQL Test 1
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Prompt 5
SQL Prompt 5 forum

SQL Prompt 6 issue with SQL Test 1

Search in SQL Prompt 5 forum
Post new topic   Reply to topic
Jump to:  
Author Message
blitzd



Joined: 26 Nov 2010
Posts: 32

PostPosted: Thu Jul 04, 2013 8:20 pm    Post subject: SQL Prompt 6 issue with SQL Test 1 Reply with quote

I recently installed the EAP of SQL Prompt 6 at the recommendation of one of the support folks, V5 had been crashing VS2012 on close - and the EAP 6 version did indeed seem to fix it.

However, now when I am running the EAP 6 version and authoring a query against a database I end up with SSMS entirely locking up. It doesn't crash, it just becomes unresponsive until I end task with the task manager. Looking in the application log I can see this particular error repeated over and over again during the periods when it's locking up with the source of each being SQL Test 1:

#QEc.#mRA
#1:Failed to load assembly RedGate.SQLPrompt.CommonUI.resources, Version=6.0.0.15, Culture=en, PublicKeyToken=7f465a1c156d4d57

Or sometimes with a variation on the Culture:

#QEc.#mRA
#1:Failed to load assembly RedGate.SQLPrompt.CommonUI.resources, Version=6.0.0.15, Culture=en-US, PublicKeyToken=7f465a1c156d4d57

#QEc.#mRA
#4:Failed to load assembly Microsoft.SqlServer.Management.SqlStudio.Explorer.resources, Version=11.0.0.0, Culture=en, PublicKeyToken=89845dcd8080cc91

#QEc.#mRA
#10:Failed to load assembly RedGate.SQLTest.Model.resources, Version=1.0.14.2, Culture=en, PublicKeyToken=7f465a1c156d4d57

#QEc.#mRA
#1:Failed to load assembly RedGate.SSMSIP.CommonUI.resources, Version=1.2.0.26, Culture=en, PublicKeyToken=7f465a1c156d4d57

etc etc...

Upon terminating SSMS I also see (with a source of SQL Prompt 5, which I no longer have installed):

2013-07-04 15:16:42,767 [1] ERROR SsmsAutomator.SsmsCommandTarget [(null)] - An error occurred while connecting
System.Runtime.Remoting.RemotingException: The remoting application name, 'SsmsAutomator.SsmsRemoteControl', had already been set.
at System.Runtime.Remoting.RemotingConfigHandler.set_ApplicationName(String value)
at System.Runtime.Remoting.RemotingConfiguration.set_ApplicationName(String value)
at SsmsAutomator.SsmsRemoteControl.Configure()
at SsmsAutomator.SsmsCommandTarget.OnConnection(Object application, ext_ConnectMode connectMode, Object addInInst, Array& custom)

So, while my initial issue of VS2012 crashing on me at close is resolved, SSMS is now crashing on me with normal use of SQL Prompt.
Back to top
View user's profile Send private message
blitzd



Joined: 26 Nov 2010
Posts: 32

PostPosted: Fri Jul 05, 2013 5:25 pm    Post subject: Reply with quote

FYI, I have since uninstalled SQL Test, SQL Connect, and SQL Source Control, and I have not yet run into the issue again. The errors listed below have also stopped showing up in the event log.
Back to top
View user's profile Send private message
Aaron Law



Joined: 28 Jun 2013
Posts: 219
Location: Red Gate Software

PostPosted: Sat Jul 06, 2013 9:05 am    Post subject: Reply with quote

Sorry this is interfering with your work.
Which versions of SQL Test, SQL Connect and SQL Source Control did you have installed?

I had the same thing annoying me but I thought I took out this line of logging in SQL Test 1.0.14.2, it looks like that might be the one you had though. It's caused by WPF constantly probing to see if a ".resources" file exists for each dll loaded, unfortunately we had logging for missing dll files.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group