Red Gate forums :: View topic - IIS 8 issue with SQL Monitor 3.3
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Monitor 3
SQL Monitor 3 forum

IIS 8 issue with SQL Monitor 3.3

Search in SQL Monitor 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
absnom



Joined: 04 Apr 2013
Posts: 4

PostPosted: Thu Apr 04, 2013 5:33 pm    Post subject: IIS 8 issue with SQL Monitor 3.3 Reply with quote

Hi,

We have installed a trial version of SQL Monitor 3.3 on a Windows Server 2012 box with SQL Server 2012 and IIS 8. I have followed the instructions for IIS at:

http://www.red-gate.com/supportcenter/Content/SQL_Monitor/help/3.2/SM_UsingIIS

and

http://www.red-gate.com/supportcenter/Content/SQL_Monitor/help/3.2/SM_ASP_issues


However, when I attempt to go the home page of the app, I get a routing error from IIS 8:

HTTP Error 404.0 - Not Found


Detailed Error Information:

Module IIS Web Core

Notification MapRequestHandler

Handler StaticFile

Error Code 0x80070002


Requested URL http://localhost:4444/UrlRouting.axd

Physical Path C:\Program Files\Red Gate\SQL Monitor 3\WebSite\UrlRouting.axd

Logon Method Anonymous

Logon User Anonymous

Request Tracing Directory C:\inetpub\logs\FailedReqLogFiles


There is, of course, no UrlRouting.axd. The fact that it is looking for one seems to indicate there is something mis-configured about the routing - but what? Appreciate any insight. Thank you.
Back to top
View user's profile Send private message
chriskelly



Joined: 19 Apr 2010
Posts: 327
Location: Cambridge, UK

PostPosted: Mon Apr 08, 2013 3:53 pm    Post subject: Reply with quote

Unfortunately configuring IIS is something that we are unable to support you with. This is because IIS is incredibly difficult to debug when the error message are quite vague.

Having said that though, I would recommend that you double check that you have correctly configured the application pool to use integrated mode (Application Pool > Basic Settings).
_________________
Chris Kelly
Technical Support Engineer
Back to top
View user's profile Send private message
absnom



Joined: 04 Apr 2013
Posts: 4

PostPosted: Tue Apr 09, 2013 5:43 pm    Post subject: Reply with quote

Thanks. Understand. Yes, checking that the application pool was set to integrated mode was one of the first things we did.

Fortunately, we managed to get it working yesterday. It turns out that something had changed in our web.config file. We never manually touched it, it was changed via the IIS Manager, as we adjusted settings. However, we kept a copy of the original web.config file and simply replacing the altered config file with the original was sufficient to get it working.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group