Red Gate forums :: View topic - Update from version 3.0 to 3.2 port error
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Monitor 3
SQL Monitor 3 forum

Update from version 3.0 to 3.2 port error

Search in SQL Monitor 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
hangeles



Joined: 28 Nov 2012
Posts: 3

PostPosted: Wed Nov 28, 2012 5:51 pm    Post subject: Update from version 3.0 to 3.2 port error Reply with quote

running the installer for version 3.2 to upgrade from version 3.0. when i get the base Monitor port number test, it says the port is unavailable. This is obviously true since the old install is using it. Am i missing a step here? is the installer not able to pick up the older version and upgrade it?
Back to top
View user's profile Send private message
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Thu Nov 29, 2012 6:24 pm    Post subject: Reply with quote

The installer stops and disables the old version but if something is keeping a handle on the service, it is unable to overwrite with the new version. The services.msc app is particularly annoying in this respect. If that's open then close it and retry the installation.

I have seen the issue but it always seems to resolve itself. Are you still having problems?

Regards
Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
hangeles



Joined: 28 Nov 2012
Posts: 3

PostPosted: Fri Nov 30, 2012 3:13 pm    Post subject: Reply with quote

The installer never offers to update the previous install. I have to manually select 'Use existing IIS Web Server', which I thought would get detected.

I still get the 'port is not available' error
Back to top
View user's profile Send private message
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Fri Nov 30, 2012 3:46 pm    Post subject: Reply with quote

Our installer just overwrites the existing files. The only real 'upgrade' done is to the data repository. The way this works could definitely be improved.

What version of IIS have you got out of interest? As far as I'm aware, the IIS auto-detection has worked fairly well in the past.

Would it be possible for check services.msc to see if "SQL Monitor 3 Base Monitor" is still running? If it is it could be worth stopping it before retrying the installer. The installer should be disabling this service but it doesn't appear to be working correctly in your case.

Regards
Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
hangeles



Joined: 28 Nov 2012
Posts: 3

PostPosted: Fri Nov 30, 2012 3:56 pm    Post subject: Reply with quote

Thanks Chris, I did not realize I had to manually turn off the service. I was expecting the installer to handle that. After that, the install worked as expected.
Back to top
View user's profile Send private message
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Fri Nov 30, 2012 4:00 pm    Post subject: Reply with quote

Yes the installer definitely should handle that but it's possible that we have a bug that means that occasionally it doesn't.

Good to hear the install worked eventually :)

Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group